Android Client stuck on grant access


Linux and Windows clients work fine. Android app stays stuck on “grant access”. Netxcloud instance is running on nginx and sitting behind haproxy with ssl offloading.

No errors in the nextcloud or nginx logs… any help will be appreciated !

Hi @Steel_PC , did you check/try (Solved) Client won't connect to server - Usual fix didn't work already?

Hello ! Yes I did but none of it worked…

Some news. If I had :443 to my domain in the app I get through the grant access part :slight_smile:

I still get a “Server in maintenance” in the main part of the and no folder or file is showing.

Here is what I get in nginx access log

[28/Apr/2021:16:01:07 +0200] "GET /status.php HTTP/1.1" 503 5 "-" "Mozilla/5.0 (Android) Nextcloud-android/3.16.0 RC2" "" "NC_DOMAIN" sn="NC_DOMAIN" rt=0.033 ua="unix:/run/php/php7.4-fpm.sock" us="503" ut="0.032" ul="19" cs=

If I check the NC_DOMAIN/status.php from a browser


Figured it out ! … No need for :443 …

'csrf.optout' => 
  array (
    4 => '/Nextcloud-android/',
1 Like

Glad to hear you found the issue :slight_smile:

1 Like

I experienced all the symptoms you described, getting stuck on the Grant Access page, with the hosting being behind a reverse proxy.

What solved it for me was to log in through the browser on a PC, go to the Security settings tab, and Create a new app password. I logged in with this instead of the main username and password.