(Solved) Client won't connect to server - Usual fix didn't work

Fixed with addition of config value:

‘trusted_proxies’ => [‘w.x.y.z’],

I have NC21 installed on Apache Linux behind an Nginx proxy. The proxy handles the SSL. My config.php includes the line:

‘overwriteprotocol’ => ‘https’,

but I am still stuck. The android client gets stuck at the Grant Access point. I tried the Linux client, and it was clear that the server thought I was trying HTTP instead of HTTPS because it complained that:

“The information you are about to enter is insecure” at the grant access point.

What am I missing?

Hi cj,

if you are sure that you have setup NGINX correctly, then on your config you should add the following lines:

‘trusted_domains’ =>
array (
0 => ‘YOUR_NC_DOMAIN_HERE’,
),
‘overwrite.cli.url’ => ‘https://YOUR_NC_DOMAIN_HERE’,
‘overwriteprotocol’ => ‘https’,
‘overwritehost’ => ‘YOUR_NC_DOMAIN_HERE’,

PS: You may need to add your NC domain Port with :PORT_NUMBER

I hope this helps

Thanks for the tips. These are implemented and its running well