After update to PHP 7.3.20 I can't login anymore

Nextcloud version: 18.0.6 -> 18.0.7
Operating system and version: Ubuntu 16.04
Apache or nginx version: Apache 2.4.18 (backported patched, built 2020-06-15)
PHP 7.3.20

The issue you are facing:

After plesk updated my PHP Version to PHP 7.3.20 login wouldn’t work anymore. I stumbled upon a similar post here and was told to open my own thread for this. So, here we go :slight_smile:

Is this the first time you’ve seen this error? Yes

Steps to replicate it:

  1. call login page
  2. login
  3. Receive 503 service unavailable notice.

The output of your Nextcloud log in Admin > Logging:

I can't login.

This happened when Plesk updated to PHP 7.3.20 with Nextcloud 18.0.6
I tried using PHP 7.2.32, but got the same issue.
My phone alerted me that 18.0.7 is available, so I used the command line updater and updated to 18.0.7.
After this, I could log in again and use it just like normal. After 5 minutes, I got the 503 message again.

What can I do?

To reply to your comment in the other thread:
I have Plesk 17.8.11, maybe this is why the php-7.4 repo is missing.I can’t update as my provider won’t give me a new license for the 18 version.

I’d like to add it to plesk, but don’t know exactly where plesk saves its repos.

is it described here?

1 Like

Sort of. But it is just a workaround, not a fix for the broken PHP 7.3. And a rather dirty one if I have to manually compile a new PHP version every single time an update rolls around.

I am still searching as to what happened for PHP 7.3.19 to be compatible and PHP 7.3.20 breaking the system. This must be fixable without tinkering a custom PHP version, as others report 7.3.20 as working.
And interestingly enough: After I updated Nextcloud, it worked for about 5 minutes, before serving the 503 again.

well. i would install php 7.4 instead of compiling a php.
assuming that you run on ubuntu/debian.

and since you pay for using plesk you should open a ticket. they should fix the broken version.

Ticket: Of course, already did. No response there. But seeing other users here having the same issue, I chimed in.

Installing PHP 7.4 through the link you gave me entails compiling it myself. That is part of the walkthrough they give.

which distro you are using? ubuntu/debian/centos?

disclaimer: i’m not an plesk expert. do backups.

you may try one of this https://computingforgeeks.com/how-to-install-php-on-ubuntu/ to install php-7.4 on ubuntu. for other distros ask google.

but that may screw up your server completely.

to integrate this php version into plesk you have to use the command under 2- Register the custom PHP version in Plesk

Hi,

as stated above: Ubuntu 16.04 LTS.

From time to time a login seems to be possible, but after about a minute or two, I will see the 503 again. I managed to navigate to the settings page and nextcloud reports that it can’t use the opcache module.

But opcache ist installed, also for the newest version of php. It is enabled in plesk and I checked the config files.

Sadly, I wasn’t able to access /info.php yet. Maybe I’ll get some more information there.

For my part, I installed updates within Plesk, I did not change the PHP version. I am using PHP 7.2 and since the update I can not log in anymore. My installation became unusable.

1 Like

Can you test this?

Plesk -> Domain -> PHP settings:

Under disable_functions type none.

As additional instructions add the following code:

opcache.enable=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
1 Like

Is there a reason why you use PHP 7.2 and not PHP 7.4?

1 Like

Hi Mark,

thanks for your time. Sadly, I do have these settings all along.

Best from Germany

Can you test install PHP 7.4 under Plesk -> Tools and Settings -> Update and switch your domain to it?

1 Like

Hi Mark,
I have PHP 7.4.8 FPM/Apache.
With this enabled, I get “Internal Server Error” from the frontend, and the log just tells an Error 500 “GET / HTTP/1.0”…

1 Like

Additionally, I found in the vhost error log:
AH01070: Error parsing script headers

1 Like

Okay. Can you try FPM with Nginx?
If that fails too, please check the following:

Permission
PHP timeout
Incorrect code in .htaccess (when FPM runs over Apache)
PHP memory limit

1 Like

https://bz.apache.org/bugzilla/show_bug.cgi?id=57198

1 Like

FPM/Nginx results in absolutely the same problem.
Permission did not change, but checked them, looking good.
max_execution_time is 90, but the frontend error is appearing immediately without load time.
.htaccess is untouched.
memory_limit is 256M which should be enough… tried 512M without effect…

1 Like

Hi Mark,
as written above: PHP 7.4 is not an option. I don’t get it offered with Plesk Onyx, and I don’t get the license from my hoster to upgrade to Obsidian. 7.3 needs to get fixed.
Additionally, some plugins of nextcloud don’t work well with 7.4 yet.