Add members to contact group how?

NC27

My intention is to create group of contacts and so be able to send out an info mail to a group of contacts.

In the contcats app, I can create a group, but I am not able to add any contcats to it. A search dialog opens, but what ever I enter there, nothing is found and adden to the group.
Is there some trick to add contcats?

BTW, any CLI commands can not be used here as we do not have access to the linux, only to the GUI.

Hi @ottosykora,
Might be related to mis-configuration. You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Screenshots are also helpful if you are stuck on a specific thing. Thanks.

I am not able to fill this because I do not know how to find the information needed.

I operate only from gui of nextcloud and can not find what is in linux

My NC27

it runns on ubuntu

that is all I know

Are you able to add a group as shown in this screenshot…

Nextcloud is not an email server so it only handles emails as well as whatever email service you use allows. That is why this can be confusing to troubleshoot.

No, not able

Okay, then back to the original request

Hi @ottosykora,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

I did go to the link, but there is no way I can fill in anything

how do I fill in the form?

The NC27

Linux 5.15.0-76-generic x86_64

no idea where to get all the other infos

php Version: 8.1.20

ubuntu–vg-ubuntu–lv

Mount: /
Filesystem: ext4
Size: 507.56 GB
Available: 486.20 GB
Used: 5% (21.37 GB)

Operating System: Linux 5.15.0-76-generic x86_64

CPU: Unknown Processor

I have no idea how to get other parts

Hey,

I’m afraid, but it’s not possible to use contact groups from contacts in mail.
It only works for regular groups created in the Nextcloud user management.

I’m seeing the same issue.

Hey,

I mixed something up. It’s not possible to add contacts from the system address book to contact groups right now.

In fact, a contact group is used for mail, but I can not add any members to it.

As real user groups can not be created or added in the current NC27, how is it possible to use contact groups and what are they mean for ?

I created here a contact group TEC11. This is offered as mail destination, but there seem to be no way to add some users to this group.

Can someone enlight me how to add users or what is contact group mean to be?


Currently, it’s only possible to add your contacts. That’s a contact created via the “New contact” button.

To group contacts :wink: But it’s currently not possible to use contacts from the system address book because they do not belong to you.

I understand that sounds a bit weird. The technical background is that the group membership is stored as a property in the vcard file. Contacts from the system address book are read only and therefor you cannot assign a group.

but whom belog the contacts then?

neither group admin nor the main admin is able to do anything with the contacts

It is not possible to add the same contact again as it already exists

Now, I created a contact group.

I added some ‘new contacts’ and they did land in the group really.

Now when I go to the group and select ‘send email’, my defaoult mail client opens a new message, but the address is empty. The same does happen with when bcc is selected, no addresses are included.
So what are contacts groups for?

To send a mail to a user group is not possible because it is not possible to create a user group at all.

We are jsut small groups of users and aim is to pass some links and few other things from Nextcloud to all memebers.

Is this something what Nexcloud is definitely not able to fulfill?

This is what I tried too. Mail does not accept this.
Also it is currently not simply possible to create groups of users.

Mail seems to be accepting contcat group as target, but as it is empty,
when I press send, nothing will happen.

What would be cointact groups for otherwise?

The contacts belong to the system.

Indeed, creating groups via user management is broken in 27.0.0.
The patch is already merged and will be released as 27.0.1 on 2023-07-20.

Works fine for me. Did you set an email address for the contacts? :wink:

To group your contacts.

Yes, I have email in all contacts. Still not possible to send mail to a contact group.
I entered manually new contacts, just to include them in a contact group.
But such contact group seem to have no function.

Therefore my question why would someone create a group of contacts when it is not possible to use it for something. Just to make group so the group is created can not be the aim. Such group must have some use, otherwise it is just doing something for entertainment.

And indeed, unlikely the problem with the user groups, contact groups can be created, but it can be filled only with new separately created contacts. Then this group can be observed and deleted again as this is the only tasks I could use it for so far.

My aim is, create group to which I can send infos via mail.
This should go via the mail in the nextcloud.

I would recommend waiting for 27.0.1 and using a user group.

It’s possible in Nextcloud Mail to set a user group as recipient, but it also allows you to share files, etc. with a group.

To group your contacts :wink:

Contact groups were there before the system address book. It is not compatible with the system address book, but you can still group your contacts in groups. That’s the whole purpose.

The mailto feature works for me as well. However, the format does not play well with our mail client. I will see what we can do here.

on my side it opens my defoult mail client (thunderbird) but with no recipients in it.

So yes, I managed to make a group of contcats, but this is all. I can only view the group, but nothing else, which seems to me quite strange reason to make the effort to group contcats.

Hi, in my case I amble tot add contacts to contact groups but only 31 of the 126 contacts showing up under “All contacts” , 125 of them are in imported in one map. I see the first 31 but number 32 and up are not showing at all, although the popup window extends with a lot of blank space.