500 Internal Server Error, No Folders Visible, No Errors in Log

Since upgrading to the Nextcloud 3.0.0 iOS app, all of my files have vanished from the app and every time I load it I get a 500 Internal Server Error banner showing in red in the app every time I load it.

This makes the app mostly useless - however it does seem to be autouploading my photos still, so it’s clearly not totally broken.

No logs are showing up in my Nextcloud admin console related to this problem at all.
All other clients, including Windows, Linux, and Web|CalDAV access via GNOME are all working fine.

I have tried resetting the App

I have uninstalled and reinstalled the App

I have toggled both “Most Compatible” and the new “Live Photo” features

At the time of installing the app I was running latest Nextcloud 18.x (using the Docker Containers, following the standard docker-compose method with mariadb, php-fpm and nginx)

I tried upgrading to Nextcloud 19.x with no change to the situation.

And all of the above symptoms happen on both my iPhone and my iPad, when using WiFI or LTE.

Anyone with any clue how to get things working again?

3 Likes

Great to read, that someone has the same problem. Exactly the same here.
Server is 18.0.6 running on Debian buster.
iPad and iOS App Version 3.0.0.76
Upload is working, also “Medien” tab.

The tab “Dateien” (german App) is not working.
I tried to delete the account, reinstalled the app and logged in again (using old method and web login, also QR Code).

Cannot see anything suspicious in the logs.

1 Like

Bump. I’m having the same issue, when uploading a photo from my iPhone I get an error message “500 internal server error” on the app.
Server 18.0.3 - docker container
iPhone Xr on iOS 13.5.1 and NextCloud App 3.0.0.76
Linux (Manjaro/Arch kernel 4.19) works fine for uploading data.
Downloading and viewing photos or files on the iPhone still works as expected. It’s just uploading that has a problem.

Snippet below with identifying information removed. Looks like the Nextcloud server thinks iOS is a suspicious login now and is blocking the connection. I haven’t discovered how to allow this connection, but this seems to be a step closer to getting it to work.

Hey, I have the same issue. No errors in the log, just always the error in the iOS app “error 500 internal server error”. Media and favorite tabs are working fine, just the tab “Dateien” is dead. All the other clients are working fine with my nextcloud.

Server version: 18.0.4
App version: 3.0.0.76

Update: I got my server to work again. While I can’t fully determine this was what was wrong in your case nor recommend my solution to you, I will share it in case it helps.

I tried to reboot the server, at first just restarting the docker containers, then restarting the machine. This alone did not fix the server only making it temporarily worse. The server had mariadb server installed and I forgot why so I removed it because it was causing a conflict with the docker container for the database. Next use docker-compose down from the server’s folder containing the docker-compose.yml file. Finally I used docker-compose up -d in the same folder and got no errors with the nextclouddb container.

So my host system needed a reboot and all mysql servers uninstalled, and the docker container needed to be brought down and back up. The docker-compose restart command does not shut down the container properly and you’ll need to use the down/up commands instead.

I have some more information. Today a new version was released (3.0.1.18) but the error persists.
I tried some things and have more information:
When I marked a file as favorit (in Webinterface), it shows up in “Favoriten” and in “Dateien”. After unchecking favorit, it disappears from “Favoriten” but stays visible in “Dateien”.

Also i can add a new folder by turning on Photoupload. It creates the folder “Photos”.
So it seems, the app can only see, what it created by itself.

Hi … same observation here, and a bit more detail:
iOS app works fine for 1st installed NC instance
iOS app file access fails for 2nd installed NC instance
Favorite workaround works for 2nd instance

New Program Versions:

  • Nextcloud 18.0.7 Debian Buster
  • iOS 13.5.1 iPhone xs max and iPad OS 13.5.1 on iPad 5th gen
  • Nextcloud App 3.0.1.18

same Error: 500 internal Server error when accessing files Tab

Nextcloud Server works fine with

  • Nextcloud Client Desktop Client for Windows 2.6.5
  • Nextcloud App for Android 3.12.1
  • Webinterface
  • WebDAV Windows

Some new information:
There seems to be something wrong with the user account. If I create a new one, the app works fine. I already tried a few things:

  • adding user to admin group and back
  • modifying password
  • logging in via app QR code or password

How can I check my user or “refresh” it?

SOLVED:
There was an old share for my federated cloud ID from the Nextcloud of a friend. It wasn´t visible in his Nextcloud anymore, so he removed it from the database table oc_share and I had to remove it from my database table oc_share_external. Now the error 500 is gone!

So, the iOS app has a bug, with handling unreachable shares.

Hope this is of help to someone!

1 Like

Thank you! This worked wonderfully!