Zugriff gewähren lädt ohne Ende

Hallo zusammen,

ich bin ein Newbee und habe Probleme beim Verbinden der Desktopversion mit dem server. Einloggen und alles geht, aber beim Zugriff gewähren lädt es unendlich, ohne dass es weiter geht.
Hatte dieses Problem auch schon jemand?
Hat jemand einen Tipp?

Danke euch

Hallo Neuling :slight_smile:

beim Beantworten von Fragen helfen immer Infos wie Versionen die Du verwendest.
Weiter haben sowohl der Server als auch der Client eine Logfunktion.

Bitte mal hier danach suchen und die Logs anschauen.

1 Like

aufgrund von deutscher anfrage und deutschen antworten ins deutsch-subforum verschoben

Bei der Suche bin ich auf diesen Thread gestoßen.

Ich habe das gleiche Porblem, habe daher bereits den Anbieter gewechselt (Von Hetzner nun auf Cloudron). Nun aber auch gleiche Fehlermeldung wie oben beschrieben.

Ging mir mit Windows 10 und der von NC bereitgestellten, aktuellen App. Nun auch mit Linuxmint XFCE und der App, die unter Anwendungen geladen werden kann.

App hängt sich ewig beim ‘Zugriff gewähren’ auf.
Hat jemand eine Idee? Danke im Voraus!

@Buddhaplautze

auch für dich wäre es von vorteil, würdest du den hinweis von @rakekniven befolgen.

dir von dir gelieferten “infos” sind nicht ausreichend

Hallo,
Ich hatte das selbe Problem. Bei mir war der Fehler, dass ich in den Benutzernamen Leerzeichen hatte. Ohne funktioniert es.

Ich habe jetzt den gleichen Fehler, nachdem ich mein Betriebssystem geändert und den Client neu installiert habe.

BS: MacOS 10.14.3
Client: 2.5.1final (build 20181204)
Server: 15.0.5

Das Anmelden im Nextcloud Verbindungsassistent funktioniert scheinbar, allerdings kommt dann im Log folgende Fehlermeldung, bevor das Fenster zum Gewähren des Kontozugriffes aufgeht:

Undefined index: extension at /home/users/drei-acht-vier-null/www/nc/apps/files_versions/lib/Storage.php#471

danach erscheint unendlich lange

35

Und im Log erscheint zwei mal “Login failed”.
Dabei scheint es egal, ob ich meinen Benutzernamen (mit Leerzeichen) oder meine Mail-Adresse verwende.

Ich kann bestätigen, dass der Verbindungsassistent bei Benutzernamen ohne Leerzeichen ohne Fehler durchläuft.

vielen Dank für einen Anstoss zur weiteren Suche, wie ich Benutzer mit Leerzeichen durch den Verbindungsassistent bekomme.

Die Lösung für dieses Problem ist die gleiche wie für das nicht funktionierende OnlyOffice bei der Einrichtung mit Docker:

docker exec -it -u www-data NAME_NEXTCLOUD_CONTAINER bash -c './occ config:system:set overwriteprotocol --value="https"'

4 Likes

Sorry dass ich den alten Thread wieder raushole aber sollte jemand das Problem haben ohne Docker installiert zu haben sieht die Lösung wie folgt aus:

Einloggen auf deinem SSH und in den Ordner der Nextcloudinstallation wechseln. (z.B. /var/www/html/nextcloud)

Anschließend folgende Befehle eingeben:

chmod 700 occ
sudo -u www-data ./occ config:system:set overwriteprotocol --value="https"

Gruß

Gutscho

5 Likes