Your web server is not properly set up to resolve `.well-known` URLs, failed on: /.well-known/caldav

FreeBSD nextcloud 13.1-RELEASE-p9 FreeBSD 13.1-RELEASE-p9 n245429-296d095698e TRUENAS amd64
nextcloud - version: 29.0.1.1
Caddy v2.6.4 h1
PHP 8.1.17

I have read a lot of other posts but I’m just to confused. Sorry about that :frowning:

I have just updated nextcloud and now i have a nice new warning that i didn’t have before.

Your web server is not properly set up to resolve .well-known URLs, failed on: /.well-known/caldav

Caddyfile Configuration:

{
  email x@xxxx.co.uk
}

xxxx.co.uk {
  root * /usr/local/www/nextcloud
  file_server
  log {
      output file /var/log/xxxx.co.uk.log
  }
  php_fastcgi 127.0.0.1:9000 {
      env front_controller_active true
  }
  header {
      # enable HSTS
      # Strict-Transport-Security max-age=31536000;
  }
  redir /.well-known/carddav /remote.php/dav 301
  redir /.well-known/caldav /remote.php/dav 301
  redir /.well-known/webfinger /index.php/.well-known/webfinger 301
  redir /.well-known/nodeinfo /index.php/.well-known/nodeinfo 301
  @forbidden {
      path /.htaccess
      path /data/*
      path /config/*
      path /db_structure
      path /.xml
      path /README
      path /3rdparty/*
      path /lib/*
      path /templates/*
      path /occ
      path /console.php
  }
  respond @forbidden 404
}

config.php

<?php
$CONFIG = array (
  'passwordsalt' => '/',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'localhost',
    1 => 'xxxx.co.uk',
    2 => '192.168.2.150',
    3 => '192.168.1.109',
    4 => '192.168.1.105',
  ),
  'maintenance_window_start' => 3,
  'datadirectory' => '/mnt/files',
  'dbtype' => 'mysql',
  'version' => '29.0.1.1',
  'overwrite.cli.url' => 'https://xxxx.co.uk/',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/var/run/mysql/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '==',
  'installed' => true,
  'instanceid' => '',
  'logtimezone' => 'Europe/London',
  'default_phone_region' => 'GB',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '1',
  'logrotate_size' => '104847600',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'redis' => 
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
  ),
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'overwritehost' => 'xxxx.co.uk',
  'overwriteprotocol' => 'https',
  'htaccess.RewriteBase' => '/',
  'mail_from_address' => 'x',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => 'xxxx.co.uk',
  'mail_smtphost' => 'smtp.aa.net.uk',
  'mail_smtpport' => '587',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'x@xxxx.co.uk',
  'mail_smtppassword' => 'x',
  'maintenance' => false,
  'memories.exiftool_no_local' => true,
  'memories.vod.path' => '/usr/local/www/nextcloud/apps/memories/bin-ext/go-vod-amd64',
  'memories.vod.ffmpeg' => '/usr/local/bin/ffmpeg',
  'memories.vod.ffprobe' => '/usr/local/bin/ffprobe',
  'theme' => '',
  'enable_previews' => true,
  'enabledPreviewProviders' => 
  array (
    1 => 'OC\\Preview\\PDF',
    2 => 'OC\\Preview\\Image',
    3 => 'OC\\Preview\\Photoshop',
    4 => 'OC\\Preview\\TIFF',
    5 => 'OC\\Preview\\SVG',
    6 => 'OC\\Preview\\Movie',
    7 => 'OC\\Preview\\MKV',
    8 => 'OC\\Preview\\MP4',
    9 => 'OC\\Preview\\AVI',
    10 => 'OC\\Preview\\JPEG',
  ),
  'auth.webauthn.enabled' => false,
  'app_install_overwrite' => 
  array (
    0 => 'apporder',
  ),
  'log.condition' => 
  array (
    'apps' => 
    array (
      0 => 'admin_audit',
    ),
  ),
  'logfile_audit' => '/var/log/nextcloud/nextcloud.log',
  'trusted_proxies' => 
  array (
    0 => '127.0.0.1',
  ),
  'memories.db.triggers.fcu' => true,

I dont know if the .htaccess is needed or not but just ask and i shall provide it.

If i curl -I https://xxxx.co.uk/.well-known/caldav if get what looks correct for all 4 URL’s:

HTTP/2 301 
alt-svc: h3=":443"; ma=2592000
location: /remote.php/dav
server: Caddy
date: Fri, 24 May 2024 19:05:28 GMT

Hope someone can advise, thx.

Try to change:

to:

  redir /.well-known/carddav /remote.php/dav/ 301
  redir /.well-known/caldav /remote.php/dav/ 301

(note the trailing slashes just before 301)

Ref: [Bug]: NC29 .well-known URLs, failed on: /.well-known/caldav · Issue #45033 · nextcloud/server · GitHub

1 Like

my hero :smile: Many thx :+1:

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.