Your remote address was identified as "172.18.0.1"

In the admin panel I’m seeing:

“Your remote address was identified as “172.18.0.1” and is bruteforce throttled at the moment slowing down the performance of various requests. If the remote address is not your address this can be an indication that a proxy is not configured correctly. Further information can be found in the documentation :arrow_upper_right:

I’m using nginx configured with the instructions here: all-in-one/reverse-proxy.md at main · nextcloud/all-in-one · GitHub
How do I fix this?

Hi, see What if the correct remote ip-address is not shown in the Nextcloud logs when login fails? · nextcloud/all-in-one · Discussion #2045 · GitHub

hasn’t helped

/etc/docker/daemon.json didn’t exist when ran sudo nano to that address and I created it with the userland proxy config.

is that correct?

I had the 2 and the 7 swapped around, correcting that resolved the issue

1 Like

Not using Docker so not sure how this works in my case. I am running nextcloud on freebsd in a virtual box and started seeing this error today after upgrading. Where is this address set? 192.168.0.1 is the router’s LAN address. Why doesn’t nextcloud use the IP address of the host it’s running on or the DNS name in its settings?

Where is this address set? 192.168.0.1 is the router’s LAN address.

It is the IP address of the device you’re connecting from. Or, if you’re hitting NAT somewhere (sounds like it), the address of the NAT device.

This error - at least when it’s one your own IP addresses listed - indicates you have a misbehaving client (e.g. invalid password) in your environment (or did recently). If you’ve already fixed the problem, that message will go away on its own within 24 hours, but you do have some options if you prefer:

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/bruteforce_configuration.html

Why doesn’t nextcloud use the IP address of the host it’s running on or the DNS name in its settings?

Because the indicated IP address is the one that your client device is using to connect to Nextcloud Server.

a traceroute from my laptop (where I am accessing nextcloud) shows:
traceroute to www (192.168.0.26), 64 hops max, 52 byte packets 1 www (192.168.0.26) 3.296 ms 3.729 ms 3.540 ms
I don’t see a hop to the router or NAT involvement.

Also not seeing the error now but just in case it recurs.