Your installation has no default phone region set

Server configuration detail

Home Server:
Bare Metal, 8-core, 16gb, 30Terabyte Spinning Rust

Operating system: Linux 5.15.0-57-generic #63-Ubuntu SMP Thu Nov 24 13:43:17 UTC 2022 x86_64

Webserver: Apache/2.4.54 (Debian) (fpm-fcgi)

Database: pgsql PostgreSQL 14.6 on x86_64-pc-linux-musl, compiled by gcc (Alpine 12.2.1_git20220924-r4) 12.2.1 20220924, 64-bit

PHP version: 8.0.26

Modules loaded: Core, date, libxml, openssl, pcre, sqlite3, zlib, ctype, curl, dom, fileinfo, filter, ftp, hash, iconv, json, mbstring, SPL, PDO, pdo_sqlite, bz2, posix, readline, Reflection, session, SimpleXML, standard, tokenizer, xml, xmlreader, xmlwriter, mysqlnd, cgi-fcgi, apcu, bcmath, Phar, exif, gd, gmp, imagick, imap, intl, ldap, memcached, pcntl, pdo_pgsql, redis, smbclient, sodium, zip, libsmbclient, Zend OPcache

I have looked all around to find a fix for this but i can not … all older versions or not DOCKER Versions. And non for the newest versions. I know thjat it does not mean a lot but i would like to see if there is something i ca do to Fix the error

Thanks John G

usually this error comes from the nextcloud config → config.php file.

Canb you check if you have these lines in your nextcloud config.php?

‘logtimezone’ => ‘Europe/Berlin’,
‘default_phone_region’ => ‘DE’,

The language should be configured to your needs.

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html#default-parameters

Thanks … I seem to have a small problem … I installed plain docker and it that i installed nextcloud 25.0.2 AIO

The problem is i cant find where the CONFIG file it … Any help?

thanks

I am not using the docker AIO NC but you should try to use occ commands to set system config settings by using a command like this

sudo docker exec --user www-data -it nextcloud-aio-nextcloud php occ config:system:set default_phone_region --value=“yourvalue”

Have a look at this site

and this one
https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/occ_command.html

Ok I see what I have to add. But where is the config fill at. I’m running the docker version and the files did not show up in before www.nextcloud it’s not there did you mean there’s no menu option I can click on to change this if I can make a suggestion there should be thank you I’ll take a look and let you know

John (n3ovo) &
Therese ( kb3mhm)
Phone. (412) 344-4185
Mobile (412) 447-1686

The command i give you the hint to is an extract from the “github help for AIO users of NC”.
It shouldn’t be nescessary to look for the config file itself. By using the command itself, the option will be set.

Looking for the “inner” of the docker you’ll have to login

e.g. by

docker exec -ti “NAME-OF-THE-IMAGE” bash

If that fails first time you could stop and start the docker image by

docker stop “NAME-OF-THE-IMAGE”
docker start “NAME-OF-THE-IMAGE”

and repeat the docker command to login.
But this all is obsolete if you modify your config by using the first occ command

This doc should help:GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All In One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

thank you very much … you gave me just the help i needed… thanks again

i fixed the phone zone and then for the hell of it i ran
occ maintenance:repair

and found another problem that you might know a answer for:

  • Install dependencies
    • ERROR: Failed to install Tensorflow.js: sh: /var/www/html/custom_apps/recognize/bin/node: not found

any thoughts
John G

Sorry, no idea. That should work. If not, you can open a new issue here: Issues · nextcloud/recognize · GitHub

thanks again you have been a lot of help … I will do that , have a great day