"You don't have permissions to create files here" on external volume

I have spent most of yesterday setting up my Ubuntu 18.04 Nextcloud server. I have forwarded it over my domain using ddclient and configured SSL with letsencrypt. Everything works quite fine in that regard.

However I have a Raid 1 Array for Backup purposes that I wanted to add to my Nextcloud.
I have written an fstab file that mounts them under /mnt/R1_SATA/<partition_mount_name>.
After activating the external storage plugin and adding them to the list, I was able to access them, but not to write to them. I tried everything I know about linux file permissions and have tried:

  • sudo chown -R www-data:www-data /mnt
  • sudo chmod -R ugo+rwx /mnt

While the left collumn of ls -la /mnt/R1_SATA now looks like drwxrwxrwx, indicating full permissions, I still cannot write to the drive via nextcloud.

Some Screenshots:

Any help would be appreciated.

how are they mounted? in which format…?

Hello, thanks for answering.

They are formated as ext4, mounted via UUID to their destination, with default options.

well i forgot that you’re running a raid. never did that on a linux machine myself so I can’t tell you if that one was mounted correct…

but maybe you wanna run the fstab-check with them by setting a 2 rather than an 0 at the end of line?

Well no, the raid does not have anything to do with this. They are mounted as standard drives. I can ssh into the machine, execute vim /mnt/R1_SATA/test.txt and edit and save a file. This file alos shows up on Nextcloud! But i can’t add or edit anything on the drives from nextcloud.

Hey there,

just bumping that topic…

I have the same issue. My drive is mounted correctly, I can add, move, rename and delete any files on filesystem level as user www-data. All filesystem permissions are set correctly (775 for dirs and 664 for files)
The client gives me the same error-message of not being able to create a file due to missing permissions.

I also checked the groupfolder permissions for my user and even set them - for testing purposes - to full. - No change.

When I do a mysql check I get the following result:

mysql nextcloud -e "select path,permissions from oc_filecache where path like '%Motte%';" | head
path    permissions
__groupfolders/3/Renovierung/Kinderzimmer/Rundfenster-Mottenzimmer.odt  27
__groupfolders/3/Renovierung/Mottenzimmer       31
__groupfolders/3/Renovierung/Mottenzimmer/2017-06-29_Rundfenster-Mottenzimmer.odt       27
__groupfolders/4/Motte  31
__groupfolders/4/Motte/2010     31
__groupfolders/4/Motte/2012     31
__groupfolders/4/Motte/2013     31
__groupfolders/4/Motte/2014     31
__groupfolders/4/Motte/2010/Kalender    31

I assume, that it’s an internal mapping issue from the nextcloud database to filesystem values. In which mysql table can i find the matching permisions for id “31”, “27” and any other?