Wrong russian symbols in audit.log

Hi!
Nextcloud 15.05 with Apache, PHP 7.2 on CentOS 7.
Within web interface all characters is ok, but in the audit.log I see:

{“reqId”:“XJOsovipd892X55OlpRZ4AAAAAs”,“level”:1,“time”:“2019-03-21 18:24:18”,“remoteAddr”:“10.0.0.166”,“user”:“g.perova”,“app”:“admin_audit”,“method”:“MOVE”,“url”:"/remote.php/dav/uploads/g.perova/web-file-upload-c0083ee7a8723bccb6b3d6485a11a67b-1553181883204/.file",“message”:“File written to: “/Gazprombank/\u0414\u041e\u0413\u041e\u0412\u041e\u0420 19122019_2 (\u0440\u0430\u043c\u043a\u0430).7z””,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.140 Safari/537.36 Edge/17.17134”,“version”:“15.0.5.3”}

After “File written to: “”/Gazprombank/” is wrong symbols, file name must be on russian. How solve this problem?
Thanks,
Best regards,
Andrew.

They are in russian, but encoded in unicode: https://unicode-table.com/en/041E/

The file name is unicode encoded, where e.g. \u0414 stands for the following cyrillic character: grafik . So no information got lost at the end. I would assume you use, e.g. utf-8 as character set on your server which couldn’t be used to show the mentioned character?! (I must admit, that I haven’t double-checked thist :wink:)

Hi!
I have change locale from en_US-utf8 to ru_RU.utf8, reload httpd, but nothing changes:
{“reqId”:“XJR4tOJMxuKy-k1uUMbWSwAAAJg”,“level”:1,“time”:“2019-03-22 08:55:00”,“remoteAddr”:“10.0.0.172”,“user”:“a.syrov”,“app”:“admin_audit”,“method”:“GET”,“url”:"/remote.php/dav/files/a.syrov/Documents/%D0%98%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BA%D1%86%D0%B8%D1%8F%20%D0%BE%20%D0%BF%D0%BE%D1%80%D1%8F%D0%B4%D0%BA%D0%B5%20%D0%BF%D1%80%D0%B8%D1%91%D0%BC%D0%B0%20%D0%BD%D0%BE%D0%B2%D0%BE%D0%B3%D0%BE%20%D1%81%D0%BE%D1%82%D1%80%D1%83%D0%B4%D0%BD%D0%B8%D0%BA%D0%B0.docx",“message”:“File accessed: “/Documents/\u0418\u043d\u0441\u0442\u0440\u0443\u043a\u0446\u0438\u044f \u043e \u043f\u043e\u0440\u044f\u0434\u043a\u0435 \u043f\u0440\u0438\u0451\u043c\u0430 \u043d\u043e\u0432\u043e\u0433\u043e \u0441\u043e\u0442\u0440\u0443\u0434\u043d\u0438\u043a\u0430.docx””,“userAgent”:“Mozilla/5.0 (Windows) mirall/2.5.1final (build 20181204) (Nextcloud)”,“version”:“15.0.5.3”}

Thanks.

You wrote that you’ve changed the locale, I assume that you did this in your server environment?
If yes, please keep in mind that a web server usually has it’s own configuration parameter which defines the character set to be used.
I don’t know if this will solve your problem, but it might also be possible that the problem is base on a character mismatch between Windows and Linux.
If you ask aunt G. for this kind of problem you will find a lot of information, like https://www.zen-cart.com/showthread.php?121221-Problems-with-displaying-Russian-characters-and-UTF-8

Hi, j-ed.
I have not problem with displaying russsian symbols in browsers - I was try IE, FireFox, Chrome.
I have a problem only with “audit.log” file.
I checke codepages of MariaDB, Apache, PHP - all of them set to UTF8 codepage.
Audit.log - is critical log, without him I can’t put the Nextcloud in production mode.
What can I do next for resolve this problem?
Thanks.