Wrong adress in Welcome Mail - internal IP instead of external Domain

Hello,

When setting up my Nextcloud, I noticed that in the welcome email to new users and in the user settings at the bottom left under WebDAV, the internal IP address is used instead of the external domain.
The web interface is accessed via the external domain. If I share a file via link, a link with the domain is also created. But in the settings and in the welcome mail the internal IP is shown or in the welcome mail the button is a link to the internal IP.

I have installed the latest version of Nextcloud VM on Vmware. (21.0.0.18)
Under Administration>Design the Domain is set.
In config.php I have entered the domain under “trusted_domains” as well as “overwrite.cli.url”.

So far these steps have not led to anything.

Does anyone have an idea what this could be?

I too seem to have this issue. You by chance seeing these problems also:

I fixed the problem on my end. Bet it’s the same fix for you. Found this section of the config.sample.php and copied it into my config.php. Filled in the first two options - I already had the correct value for the last option. After that all my issues and the one you describe were fixed. :slight_smile:

/**
 * Proxy Configurations
 */

/**
 * The automatic hostname detection of Nextcloud can fail in certain reverse
 * proxy and CLI/cron situations. This option allows you to manually override
 * the automatic detection; for example ``www.example.com``, or specify the port
 * ``www.example.com:8080``.
 */
'overwritehost' => '',

/**
 * When generating URLs, Nextcloud attempts to detect whether the server is
 * accessed via ``https`` or ``http``. However, if Nextcloud is behind a proxy
 * and the proxy handles the ``https`` calls, Nextcloud would not know that
 * ``ssl`` is in use, which would result in incorrect URLs being generated.
 * Valid values are ``http`` and ``https``.
 */
'overwriteprotocol' => '',

/**
 * Nextcloud attempts to detect the webroot for generating URLs automatically.
 * For example, if ``www.example.com/nextcloud`` is the URL pointing to the
 * Nextcloud instance, the webroot is ``/nextcloud``. When proxies are in use,
 * it may be difficult for Nextcloud to detect this parameter, resulting in
 * invalid URLs.
 */
'overwritewebroot' => '',

/**
 * This option allows you to define a manual override condition as a regular
 * expression for the remote IP address. For example, defining a range of IP
 * addresses starting with ``10.0.0.`` and ending with 1 to 3:
 * ``^10\.0\.0\.[1-3]$``
 *
 * Defaults to ``''`` (empty string)
 */
'overwritecondaddr' => '',

/**
 * Use this configuration parameter to specify the base URL for any URLs which
 * are generated within Nextcloud using any kind of command line tools (cron or
 * occ). The value should contain the full base URL:
 * ``https://www.example.com/nextcloud``
 *
 * Defaults to ``''`` (empty string)
 */
'overwrite.cli.url' => '',

You are right, now it works as it should.

Thank you very much :pray:

1 Like