Wopi-host problem

I’m not the only one to encounter a Wopi-host error

I think I understand why I have this problem, but I do not see how to solve it.

I installed nexcloud on a dedicated server that I manage with Plesk in Ubuntu 14.04. Nexcloud is therefore accessible via https: //nexcloud.tld - It works very well.

Collabora / code is incompatible with Plesk in this configuration. So I installed it on a second server, a VPS to be more precise, taking care to stay in a subdomain of https: //nexcloud.tld, in this case collabora.nexcloud.tld. I only use Apache2 without Ngnix.

And I think the Wopi-host problem comes from the setting of the collabora-le-ssl.conf file from Apache2 or iptables.

Access to Wopi is allowed for a domain with the same shared IP address. I have two different IP addresses. What do you think and how to solve this problem?


Based on this information, I opened port 443 in the iptable to all winds.
I still have the error Wopi host unauthorised


I close the post. The solution is RTFM

I launched docker with the domain name of collabo instead of launching it in the domain of Nextcloud.