WOPI host did not pass optional access_token_ttl

Hi everyone,

I am having harsh time trying to have Collabora working with nextcloud11.
Everything seems fine except that opening the file, I have got the “Hoops, that’s embarrassing” popup and no file would open.
The WRN log is : wsd-00024-0026 13:51:07.454636 [ client_req_hdl ] WRN WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:255

I use devicemapper, I use debian wheezy , and uname -a retrieves 3.10.105-xenU-34-082da8f-x86_64

Thx for any help!! …

Here is my docker info ==>
Containers: 2
Running: 1
Paused: 0
Stopped: 1
Images: 1
Server Version: 1.12.2
Storage Driver: devicemapper
Pool Name: docker-202:1-141775-pool
Pool Blocksize: 65.54 kB
Base Device Size: 10.74 GB
Backing Filesystem: ext4
Data file: /dev/loop0
Metadata file: /dev/loop1
Data Space Used: 2.064 GB
Data Space Total: 107.4 GB
Data Space Available: 5.673 GB
Metadata Space Used: 1.946 MB
Metadata Space Total: 2.147 GB
Metadata Space Available: 2.146 GB
Thin Pool Minimum Free Space: 10.74 GB
Udev Sync Supported: true
Deferred Removal Enabled: false
Deferred Deletion Enabled: false
Deferred Deleted Device Count: 0
Data loop file: /var/lib/docker/devicemapper/devicemapper/data
WARNING: Usage of loopback devices is strongly discouraged for production use. Use --storage-opt dm.thinpooldev to specify a custom block storage device.
Metadata loop file: /var/lib/docker/devicemapper/devicemapper/metadata
Library Version: 1.02.74 (2012-03-06)
Logging Driver: json-file
Cgroup Driver: cgroupfs
Volume: local
Network: host bridge null overlay
Swarm: inactive
Runtimes: runc
Default Runtime: runc
Security Options:
Kernel Version: 3.10.105-xenU-34-082da8f-x86_64
Operating System: Debian GNU/Linux 7 (wheezy)
OSType: linux
Architecture: x86_64
CPUs: 1
Total Memory: 466.8 MiB
Name: ursula
Docker Root Dir: /var/lib/docker
Debug Mode (client): false
Debug Mode (server): false
Registry: https://index.docker.io/v1/
Insecure Registries:

To add information :

I switched to overlay, with a 3.18 kernel … same problem

the issue seems to be that the token is empty (access_token_ttl=0) according to the log:

[14/Mar/2017:16:16:56 +0100] TLSv1.2 ECDHE-RSA-AES128-GCM-SHA256 “GET //lool/https%3A%2F%2Fcloud.XXXX.com%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F13190_oc8e60251c8b%3Faccess_token%3DrO6lp9TXsDWwm652ZrX43bX049waZrSx%26access_token_ttl%3D0%26permission%3Dedit/ws HTTP/1.1”

Thanx for your help!!


Hi @fwed,

I found this thread with the same error message “WOPI host did not pass optional access_token_ttl”:

Here the user said he got it working:

… by following the mentioned guide:

Maybe this is something which helps you as well.


Eventually made it! … Dunno really how, but I upgraded to Debian 8 (jessie), reinstalled docker properly, sticking to overlay, and … magic, works!

Hope that helps people in my case. Thanx Schmu for your help


1 Like