Windows Sync-Client doesn't sync all files (checksum wrong)

I recently upgraded my owncloud 10 to Nextcloud 12. Mostly everything workes fine. I can access all files via the server page directly. Calendar and contacts work as well. Mobile clients work too.

But when I try to use the windows 10 sync client it gives me an error I dont understand. It tells me:
“The Downloaded File does not match the checksum, the download ist resumed”. I don’t know if this ist the correct english version of the error message as I use an german system.

Can anyone help me.

Best regards

Christian

This is a new feature in NC 12 (OC 10). Do you have this error only with one file? On several desktop clients?

Can you perhaps try with the latest owncloud-client (https://download.owncloud.com/desktop/daily/) on a test setup. Also worth to check their bug tracker for similar errors: https://github.com/owncloud/client/issues

The client is currently the same, Nextcloud just applies its own theming and the client version is a bit behind.

Hi everybody, I have the same problem. I was on ownCloud 9.1 and recently upgraded to ownCloud 10.0.0.1 and a few days later I migrated to Nextcloud 12. As long as I sticked to the present ownCloud Client, everything was fine. On one Windows 10 System I installed the recent (2.3.1 build 8) nextcloud client without beginning a new sync of all files, just pointing the client to the old owncloud directory, no problems so far. Today on my Windows 8.1 System I replaced the ownCloud client with the recent nextcloud client. But this time, I started a clean new sync and a lot of files, mostly mp3-files provide the message, Christian_von_Glahn has already referred to. I also have a german system and the original message is: “Die heruntergeladene Datei entspricht nicht der Prüfsumme, das Herunterladen wird wiederaufgenommen”. Just in case someone looks for the german error message. On the Windows 10 System, I excluded an already synchronized directory from sync, so that the directory was removed by the sync client locally, then re-added the directory and now I get the same error message. So far I rebooted the whole Nextcloud server as well as the clients.

EDIT: I installed the last 4 owncloud-Clients down to 2.2.4 build 6408, the problem is still there. BTW after installing an older client, you get a message right away to restart the client in order to update to Version 2.3.2. I hope, that before the restart I really work with the old version. Question: Why isn’t there an option to deactivate automatic updates? What if I have an even more serious problem without data access at all, I think there should be an option to stay on the older version at least for a while.

Btw, the error message can be seen in the nextcloud client app under “activity” --> “not synchronized”.

I had approximately 200 files appearing there and which could not be synchronized to my Windows machine. If you also have a rather small number of files not sychronized, you can first remove them -->synchronize -->re-add them to the original folder and it is probable, they now get synchronized. This is certainly only a solution if you do not have big amounts of unsynchronized files.

I also used the following command, which helped a different person, to show missing files in the browser view, perhaps this doesn’t contribute much to our problem here, but it won’t hurt:

sudo -u www-data php /path/to/your/nextcloud/directory/console.php files:scan --all

So far I haven’t added too much new files so I am not sure, if the problem has been solved.

I’m also experiencing this issue after migrating from ownCloud 10 to Nextcloud 12. Did a full download after installing the Nextcloud client and around 170 Files won’t sync because of checksum errors.

Things I tried:

  • occ files:scan
  • occ maintenance:data-fingerprint
  • Backup, delete and replace the files. <- worked, but impractical

Are there any news on this? Is there an issue on Github?

Update: Other workarounds are:

  • Change the modification date of the affected files and do occ files:scan, which triggers this behaviour.
  • Re-upload the files from a backup via the client.

I had the same problem with the MacOS client.
Re-upload the data or change the timestamps of the files were not possible actions since the system is in production.

I removed all the checksums and it worked perfectly.

Here how I solved the problem:
UPDATE oc_filecache
SET checksum = ''
WHERE COALESCE (checksum, ‘’) <> ‘’

1 Like

Did you create a bug report? The checksum should allow the clients to identify possible changes of files. So I’m not sure what happens if you delete them. Before manually changing things, it’s better to get in touch with developers, they then perhaps say that this can be a workaround solution (without negative effects).

Here’s the properly formated SQL. This solved my issue by invalidating the checksums, Thanks!

UPDATE oc_filecache
SET checksum = ''
WHERE COALESCE (checksum, '') <> ''
1 Like

We had the same problem on our server Ubuntu 16.04 64 bit (standards version of PHP and MySQL) with NextCloud 12.03

I confirm the solution from SystemR89 worked for us.

The SQL query performed 49497 rows modifications over 2 millions rows present in this table.

It seems only projects created with the version 11 of NextCloud were having this problem.

Please report this issue to the bugtracker.

@nickvergessen @jospoortvliet

Finally, someone posted a bug report on the bug tracker, please continue discussion there:

What effect will clearing the checksums in the database have on sync operations?
We have TB of data on 100 distributed clients; don’t want to disrupt the system too much.

I just got the same problem upgrading oc 10.0.7 to nc 12.0.7 and then immediately afterwards to 13.0.2. On an installation with 23k files some 900 entries were modified in the database. The rescan of all the files took some 15 minutes, on larger installations I’m sure this would be ultra-annoying.

The files now sync. I hope it doesn’t cause a re-sync of everything on all the users’ computers…

it seems that owncloud occ already has a way to fix that, I don’t know about it happening again though.
sudo -u www-data /var/www/owncloud/occ files:checksums:verify

That fixed it. Great!

By the way:
" sudo -u www-data /var/www/owncloud/occ files:checksums:verify" seems to be not available anymore (NC v15).

I tried this but I’m getting error oc_filecache doesn’t exist