Windows desktop sync client very slow

Only just noticed the slowness now, after upgrading from v21 to 25 in one go. Could have been slow before, not sure. It has been able to do almost the full 1 GBps before and consistently. It also sits there, spinning a lot longer than previously. On a 5GB test file it said “syncing” for close to 15 sec before it started uploading the file. When uploading large files i’m what looks like, being throttled to 2-4 MB per sec.

I can access my webdav: and it says its all good, atleast to my knowledge.

I Can upload at around 70MB/s through the webUI, so im fairly certain the issue is with the Windows NC client.

CPU usage on the containers is not high, maybe 10% at max, but RAM usage is through the roof at 8GB currently while doing nothing.
I’m not sure if i have found a bug of some sort, or it’s caused by my own lack of knowledge/config issue.

The setup:
1GBps WAN and LAN.
Unifi switches and AP’s and pfSense FW with Snort IPS/IDS activated.
Unraid 6.11.5, I7-8700k, 32GB RAM, SATA SSD cache that the data goes to first. HDD’s are Ironwolf, exos and WD Red disks. Only CMR disks.
NC 25.0.2, been upgraded a few times from V19 or V20. Docker container.
MariaDB v10.6.10. Docker container.
Nginx proxy manager v2.9.18 Docker container, with SSL enabled, with the following advanced settings.

	proxy_set_header Host $host;
	proxy_set_header X-Forwarded-Proto $scheme;
	proxy_set_header X-Real-IP $remote_addr;
	proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
	proxy_max_temp_file_size 36384m;
	proxy_read_timeout 150;
	client_max_body_size 0;

The desktop client is on: Windows 10 pro, 22H2. R7 3700X, MSI X470 mobo, 32GB RAM and NVME SSD, Windows Defender as AV.

Things i have tried:

New user

Reinstall of client, with a registry scan cleanup with Revo uninstaller.

Setting chunking size to 100MB:

docker exec -it nextcloud occ config:app:set files max_chunk_size --value 104857600

Checking if oc_authtoken table in DB is oversized. select count(*) from oc_authtoken; Only gave 7 results.

Setting php-local.ini settings;

post_max_size = 16G
memory_limit = 2G
upload_max_filesize = 50G

Connecting to the local IP of the NC instance, bypassing the reverse proxy. Same slow speed there.

Different settings in the nginx.conf file.
Probably more I have forgotten.

I have collected all the files i think could be helpful, I hope it’s sufficient otherwise ill gladly provide more information. Link to it is here: Bobby cloud

I hope someone can give me a hand in figuring this out, I’m a bit outta my depth here. Thanks!

Skipping major versions during an upgrade is explicitly not supported. This may have unpredictable effects on your installation.

What process is using up so much memory?

Thanks for your reply and taking the time to help!

I did split it up into more upgrades than just 1. I used the webGUI upgrade button thing 4 times, each time jumping a major version. Didn’t know that was a factor that could mess up your installation, so i just described it as upgraded in one go. Sorry for the mess up.

Dont know, I went to bed and it was fine when i woke up again. Might have been some cache files stuck in RAM from a failed sync operation or something. Not sure if that’s how it works.
If it does that again and i want to see the RAM usage, do i just write top in the console and that will show me all the usage right?

I also forgot to add, the docker containers I’m using for NC and mariaDB is from