Windows Desktop client is giving Network error: 302 on first time sync

I have setup nextcloud on my home server and am syncing my local files for the first time. But when I was syncing a rather large folder, I keep getting Network error: 302 in the Windows desktop client. I have no problems accessing the web portal and am a bit lost as why this issue is happening.

I don’t think my network setup has anything to do with anything but here is how its setup anyway:

  1. The server is running on TrueNAS Scale and it has a local IP and port that I can access from my network.
  2. In a separate kubernetes cluster, running on the same internal network, I am using Traefik to setup an ingress for a domain ( and routing it to the local IP and port.
  3. In the same cluster, I am also running cloudflared, a tunnel agent from cloudflare, so that requests can come into the local network in the first place.

My domain DNS is on cloudflare but I have disabled the proxy there.

The above network setup was working fine until I messed up and deleted the DB in the server, which is why I am setting things up again.

My server config is mostly unchanged except that the following env vars are set:


I have not been able to find any info so it would be great if someone could help.

1 Like

I’m having the same issue on my MacBook Pro connecting to Nextcloud in a docker container on my Synology NAS.


I don’t know if this is the same reason you’re getting this issue, but I have a nextcloud instance on my network that I VPN into with wireguard which was giving me all those network error 302s. I was googling around and couldn’t find anything, so I started messing with network settings in the nextcloud client, and found that changing the proxy from “use system proxy” to “no proxy” fixed the issue.


I have had it set to No Proxy all the time. This only happened during my first time sync and only seemed like happening when some folders were large, around 50 MB or so.

Thanks dude.

It solved my problem…