Windows Desktop client "Changes in synchronized folders could not be tracked reliably"

Hello all
Could someone give me some hints/ideas how to troubleshoot the following issue on Winsows 10 desktop client 3.1.1? After upgrading from 2.6.5 to 3.1.1 the following error message is displayed after the start of the desktop client: " Changes in synchronized folders could not be tracked reliably" (in German: “Änderungen in synchronisierten Ordnern konnten nicht zuverlässig nachverfolgt werden”)
I’ve configured 3 folder synchronisations on the client what used to work very stable in the past. Now, after the upgrade, just one of it seems to have this issue. When I add a file to a synchronized folder it’s almost synched immediately to the server on two of those sync targets. But on one of those 3 it doesn’t work.
I haven’t tested in both directions and I didn’t wait for a long time yet.

I’ve deleted the faulty folder synchronisation on the desktop client and added it again. No success. I de- and reinstalled the desktop client (just in the Windows control panel, didn’t remove some files manually). The error still appears.

Ideas?

Some more details I should provide?

Thank you very much in advance for your help.

There you have a few points for troublehshooting and where to get the logfiles:
https://docs.nextcloud.com/desktop/3.0/troubleshooting.html

Because it was working before, it looks a bit like a regression which means this is a good candidate for a bug report. Logfiles are interesting, if you find any difference in the folders, I don’t know perhaps different file system on the client, or data from external storage. Or is it always the third one, try to add a forth one and a different as third one.

I’d take a look at the bug tracker: Issues · nextcloud/desktop · GitHub, regressions easily qualify for a bug report. Just make sure that there isn’t already a topic. Ideally you find a way and procedure to easily reproduce this problem. It can also help if others with similar problems share their configuration.

Thank you! I will try it soon. The computer is currently not accessible to me. I will post the updates/findings here.

OK, here are the results of my additional testing and some more information:

  • Removed the folder that is not synched automatically and added a new folder (completely new partnership). The message still appeared after restart of the desktop client but it was one of the other folders that isn’t synchronized then. Then I added the one again that I removed and it can synch now. So the folder or its contents is obviously not the problem.
  • Synched the folder to another PC and that worked too.
  • Activated the log with F12 and can’t see something special (like an error). The log is really big and I’m a bit lost because I don’t know what to look for.
  • 2-Way synch for all other folders are working fine
  • Within the folder that doesn’t synchronize I’ve added a testfile. All other files have the green tick but the new one hasn’t. So obviously it isn’t recognized by the sync client…
  • Copied the contents of the unsynchronizable folder to another place on the same HDD, then deleted the synch partnership and added it for the new folder where the contents are copied to. Still the same problem…

update follows…

@mschwizer Did you figure this out?

Not yet. I haven’t spent more time on it. But I’ll contact the user soon to do a check directly on her computer, because she told me that she thinks everything is synchronized and fine so far. (probably with a delay?)
And meanwhile we’ve upgraded to NC Server version 19.x, so the whole environment has changed.
In any case I’ll post an update here. That issue is just not the highest prio for me, that’s why it takes longer :slight_smile:

@mschwizer, I was and am on Nextcloud 20.0.6 and the error message is not there anymore when I start my computer. No clue what it was, but it is gone. I have never seen files that where not synced. All folders give nice green checks. So hopefully for your user this also disappears after a while.

Hi!
I have this too.
I am on Client Version 3.1.3 (Windows).
All my local data is on an external hard disk
Nextcloud is a Core appliance instalation on my RPi Nextcloud box (data also on external disk)
When in dual boot Manjaro I dont have it
I also cant quite read all the info on the toast notification in windows - could you tell me the whole message, please?
Everything seems to be working well tho, AFAICS

EDIT: Found this
https://docs.nextcloud.com/desktop/3.0/faq.html?highlight=reliably
but my problem is with the client on Windows, not Linux?
Beyond my limited talents!

I just found these two blog post too:

But, as I said, my Linux (Manjaro) client is working fine, I just get this error when booted into Windows 10 with client 3.2.1

Any ideas on how to ‘setting the fs.inotify.max_user_watches sysctl to a higher value’ on windows 10?

Or could this be a different problem in my case?

My data is on an external USB disk on the laptop
My nextcloud is a ubuntu appliance on a RPi (in a Nextcloud Box) self installed

All works fine when booted into Linux on laptop

I’m now on 3.2.3 and still I get this message, anybody got any ideas?
Please?

After a long while I’ve checked the situation again. The folders are basically synched but the error message is still appearing. As I can see the files are not synched in “real time” so probably only after user log-on/-off or system boot.