Windows Desktop Client (3.5.4): Error while reading: error:1408F119:SSL routines:ssl3_get_record:decryption failed or bad record mac

Hi guys,
I freshly installed Nextcloud 24.0.4 with PHP 8.1 under Debian 11 with REDIS in a VM (8GB RAM) on Proxmox. One week ago I synced all files from my windows 11 laptop with the sync client to the (empty) nextcloud and it worked perfectly. No errors and super fast.

Yesterday I built my new windows 11 desktop PC and it is works really good except the nextcloud sync client. After downloading ~1GB of data, I get this error message:
Error while reading: error:1408F119:SSL routines:ssl3_get_record:decryption failed or bad record mac. When I force the sync again, it works for some more data but after 1 minute again the same error.

Downloading over the web interface works really good (100MB/s download and upload even for large files (5GB)). So I guess it is something about the client. But on my laptop and on my desktop is version 3.5.4 installed and it works on the laptop but not on the desktop :frowning:

Right now the nextcloud server is not publically available, so I’m using snakeoil certificates (created by openssl req -x509 -nodes -days 365 -newkey rsa:4096 -keyout /etc/ssl/private/nginx-selfsigned.key -out /etc/ssl/certs/nginx-selfsigned.crt and edited the hosts file on my desktop pc and on the laptop. Again: In the webbrowser on both devices and on my laptop with the sync client everything works fine, but only in the sync client on the pc it doesn’t work.

I also reinstalled the sync client multiple times and deleted / the account but still, the problem exists.

/etc/nginx/conf.d/nextcloud.conf:
server {
listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name mydomain.de;
ssl_certificate /etc/ssl/certs/nginx-selfsigned.crt;
ssl_certificate_key /etc/ssl/private/nginx-selfsigned.key;
ssl_trusted_certificate /etc/ssl/certs/ssl-cert-snakeoil.pem;
ssl_dhparam /etc/ssl/certs/dhparam.pem;
ssl_session_timeout 1d;
ssl_session_cache shared:SSL:50m;
ssl_session_tickets off;
ssl_protocols TLSv1.3;
ssl_ciphers EECDH+AESGCM:EDH+AESGCM;
ssl_ecdh_curve secp384r1;

ncadmin@nextcloud:~$ uname -a
Linux nextcloud 5.10.0-17-amd64 #1 SMP Debian 5.10.136-1 (2022-08-13) x86_64 GNU/Linux

ncadmin@nextcloud:~$ php -v
PHP 8.1.9 (cli) (built: Aug 15 2022 09:47:52) (NTS)
Copyright (c) The PHP Group
Zend Engine v4.1.9, Copyright (c) Zend Technologies
with Zend OPcache v8.1.9, Copyright (c), by Zend Technologies

Thank you for some ideas! :slight_smile:

I now updated to 3.6.0 RC1 (released 3 days ago) and the problem still persists :frowning:

were you ever able to fix the problem?

Sorry for my english. …
But i have to write a solution - this is very hot solution fixed a moment ago.

I try to find a solution from a months…

What i do, im using my nextcloud server on very old thinkpad i7 etc. and i
and I looked in the server configuration (nextcloud snap) and changed the openssl settings from a months as i said and nothing helped.
I started looking through the mikrotik logs looking for a solution to another issue and noticed that my ether port is going down and after 2 sec up - and thats only happen when nextcloud start sync - and sending/downloading a big file -
look


ether 1gigabit down and up , so i tried change the speed port for 100M
and ?
Its working, i’m not 100% sure the problem is solved for 100 % but for me 95% becouse
one more time that was happen,

but from changing speed syncing going continuously

before the solution sync was broken and sync was stopped on the begining
image

try to solve this problem on your router with ether port speed, problem is caused by broken connection during upload/download

i will gona paste this solution on all post where i try to solve problem.

image
image