Windows client share link without servername

nc15
#1

Hi all,
when I´m using the sync folder on windows explorer I can´t share the created link.
This is because the link is without the server. At the moment it´s like https://:443/index.php/f/249.
No server name in the copied link.
Anybody else get this?

#2

Can you show us your config.php? There could be something wrong.

#3

Sorry I´m late,
here´s the config:

$CONFIG = array (
  'instanceid' => '****',
  'passwordsalt' => '****',
  'secret' => '****',
  'trusted_domains' =>
  array (
    0 => '****',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '15.0.0.10',
  'overwrite.cli.url' => '****',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '****',
  'dbpassword' => '****',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => 'localhost',
    'port' => 6379,
  ),
  'memcache.distributed' => '\\OC\\Memcache\\Memcached',
  'memcached_servers' =>
  array (
    0 =>
    array (
      0 => 'localhost',
      1 => 11211,
    ),
  ),
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => '****',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpport' => '25',
  'mail_from_address' => '****',
  'mail_domain' => '****',
);

I don´t think that there´s something wrong.
The problem apperars only in Windows Explorer.
All works fine, except the Nextcloud -> share Button in context menu.

Thanks

#4

The trusted domains are just empty, so you don’t expose your hostname?

Same thing for the overwrite.cli.url, it should not be empty, it’s something like https://cloud.example.com or https://cloud.example.com/nextcloud, this URL is then used to generate the sharing links (it’s used especially when you pass through proxies or have different trusted domains, so you are sure that the sharing links are ok. If it is not defined, Nextcloud tries to figure it out by itself). You must not set this value empty.

#5

I just formatted the source code of your post, and it is clear that you didn’t have empty settings. Then I just ask if the overwrite.cli.url is a URL and not just a hostname.

#6

It´s a real domain:
'overwrite.cli.url' => 'https://cloud.****.de',

The asterix are only to hide my settings.

#7

I just went back to your initial post, you said it is only IE. Do you use any plugins there (antivirus, add blocker)? Can you check on one of the test setups if you see the same problem with that browser?

#8

You misunderstood me. It´s not the IE, it´s the Windows File Explorer. I´ve installed the Windows client. In the shared folder -> right click on file -> Nextcloud -> Teilen (share) is the adress missed, only https://:443/index.php/f/249 is in the link.

#9

Thanks for clarification. I tried on my own client and didn’t see a problem. Normally the overwrite.cli-stuff should give you the right hostname. Are you using a company proxy, antivirus/firewall-solutions. Perhaps try with the client and the test setups, if you see the same problem. This way, you can figure out if it is related to the client or to the server.

#10

I’m having the same issue. the hostname in overwrite.cli is correct and it works everywhere except the software client

#11

same issue here, nextcloud is installed by snap and i am running behind an apache reverse proxy