Windows 7 Virtual Files Support


I have configured nextcloud server and encountered something odd.
The windows 10 desktop client shows the virtual files option.
The windows 7 desktop client does not show virtual file option at all. The machine has managed to install nextcloud without errors.

I do realize that the minimum requirements for nextcloud are windows 10 but is there anyway to make virtual files work on windows 7?

Everything else seems to work fine in windows 7 apart from the lack of virtual files

Thanks in advance!!

Hi @TommyD

Windows 7 is EOL and should no longer be used.

Regarding the Nextcloud client, you can use the legacy version 2.4.something without VirtualDrive support. AFAIK newer versions of the client and especially the VirtualDrive support depends on some features of the operating system that are only present in relatively recent Windows 10 versions.

Check out github a bit, I can’t find it right now but I think there were some changes in Windows 10 that are required for the virtual drive feature. Or I think it was a version issue but I don’t remember where it was, might be only related to server versions.

I found this…

And my initial post wasn’t exactley correct, the legacy version I mentioned is for macOS not Windows.

However, the GitHub issue only states that the client can be installed on Windows 7 and 8.1. I can’t say from this whether the Virtual Drive feature should really work or not. I wish the developers would communicate a bit more clear, at least in the of the GitHub page, what exactly the requirements are and which features should work on which Windows version.

Either way, you can’t really expect Windows 7 to be fully supported imho, since it’s not even supported by Microsoft itself anymore. Basically, Win 10 is the only desktop OS from MS that is still fully supported. Even Windows 8.1 is already in it’s extended support period, which will end in 2023. If you want to have the latest and greatest features you should imho upgrade to a current Win 10 version.

thank you, i tried downgrading to 3.3.0 but still no dice… I do have a win 10 machine but the win7 has some softwares installed which do not work on 10 thus my reluctance on upgrading it… i’ll make do with the 10 machine for documents and use web i guess for the win 7 :slight_smile: