Win a t-shirt by testing Nextcloud 11 RC1!

Originally published at:

You don’t have a Nextcloud t-shirt yet? Here’s your chance to win one: we just released Nextcloud 11 RC1 and we are offering a t-shirt to anyone who finds a problem with the upgrade process from Nextcloud 10! On top of that, we also have RC’s of Nextcloud 10.0.2 and 9.0.55 and finders of upgrade issues in those will also be eligible for a t-shirt.

Upgrading and t-shirts

Nextcloud 11 is near to a release and today, we publish the first release candidate. This means we have tested Nextcloud 11, fixed all issues we found and can not find any more serious issues. Which means we need your help to find more!

As upgrading is the most critical operation with a new release, we’re offering anyone who finds a bug in the upgrade process from Nextcloud 10 to Nextcloud 11 a t-shirt! However, obviously any bug report is welcome, not only those about upgrading!

You can download the Nextcloud 11 file directly here or find it in the ‘Get Involved’ section (bottom right) on our install page.

Today we also publish release candidates of Nextcloud 10.0.2 and 9.0.55 and for finding Nextcloud 10.0.1 -> 10.0.2 upgrade bugs you are also eligible for a t-shirt!

Please, grab and and test them!

An alternative way of upgrading is choosing the ‘beta’ channel in the admin panel, we’ve now made Nextcloud 11RC1 available there. If you are on 9.0.x, you can upgrade to 10.0.2RC1 that way, and if you then go there again and set it to beta a second time, you will go to Nextcloud 11RC1.

And remember: if you’re brave enough to upgrade a production system, be sure to at least make a database backup!


A few simple rules for winning a t-shirt: it has to be a unreported, non-duplicate bug in the upgrade process; that is, something which goes wrong with the upgrade, not in normal usage. Also, we'll generally consider bugs due to the same root cause duplicates.

smallprint: we reserve the right to decide who gets a t-shirt, no debates possible and if we decide to reward you with a hug instead of a new shirt you should be super happy with that as human contact is very healthy!

1 Like

Thanks for the update. But no issue found. Works fine :slight_smile: only the collabora app icon is not showing in the menu.

How to be disappointed that your upgrade went fine :slight_smile:

It’s not disappointed. It’s good. I think I buy me an Shirt, if possible.

I have tried to upgrade from the admin page, but no updates were available, althought my update channel was on beta.

Switching the update channel to stable and then back to beta seems to solve the problem.

Best Regards

Also no T-Shirt for me, 'cause upgrading works fine … sad …
But an more important bug for me ist the contacts app in the nc-repos. Using oc-repos works …


PS: Maybe T-Shirt for the half-price regarding the bug with contacts :smiley:

I found one thing, after upgrading and activate some apps. Die App “collabora” is not visible at the menu. But it still works when I open an document over the filebrowser.

That is actually the expected behaviour. While the menu entry in the top left was removed we consider this the accepted behaviour because:

  1. One can create Office documents easily using the New File tab in the top
  2. Removing this allowed us to drastically speed up the startup time of Collabora (especially if a user receives external shares)
1 Like

Let’s check if this is a bug. :wink:

Even if there are many files in /settings/l10n/* there are only few languages to choose in user’s profile options. There are not listed all of them.

For example, I am searching for basque language ‘eu’ that was listed in 10.0.1 and not in 11 RC.

Regards and thank you a lot for your job!!!

It also happens when upgrading from 10.0.1 to 10.0.2
There are less languages for user to choose after upgrading even if the files in the l10n folder are the same.

I try upgrade from 10.0.1 to 10.0.2 but get a problem on step “Move new files in place”

Can you file an issue at We’d be happy to take a look in detail then.

Also, looking at the source code this happens when the response is not JSON. Can you open your network console in your browser and take a look at the response? Also is there anything in the PHP error logs?

I did’t Error step “Move new files in place” updater 10.0.1 to 10.0.2 #63

Updated from 10.0.1 to 10.0.2 in stable channel:

  • Everything works fine so far.

  • But two info files of OwnBackup didn’t pass the integrity check, thou it was updated to 16.11.0 over the new nextcloud store. As everything is working fine I don’t care and will wait for the next OwnBackup update to resolve the notification.

    [ownbackup] => Array
    [INVALID_HASH] => Array
    [] => Array
    [expected] => 04ad0a9e5212c8db98fd11696e853f3f52dd9d7bee52dd2362c3303e032875b6c9fd6a2aa5151468de99ede5e1afa527349fb81efa872b977d902040e0a3fac6
    [current] => 19292ca3fd349cb446ad6f374ab62b4b9e0f8f69c863460e53a36271c14f59fa64bc783979edbf084b423c44c3fd3860e09814320ad7f2ab6558e4b9b459bf0f

                  [appinfo/info.xml] => Array
                          [expected] => 5b6b9f1498bff49f35122a9fbe07451d0643ff35adc049c46ac1928dd005afd1de0d6d0106179dff5da2f4f85200df7cb04088d8faab97e34bfe0c265385f7a9
                          [current] => 0f0e4160fbd178b899c0da06ab56f548f1af17f07d5581badabfb93a06a37f257c1b3dbff2c608b0fe02fb285285fff6ebf7f5d8a3179426608f222a074b4add

Went on updating to 11.0 RC1 on beta channel:

  • Everything still working fine.
  • OwnNote and Tasks are not yet updated to be officially compatible with Nextcloud 11, so they can’t be enabled anymore. Adjusting their info.xml resolves it.
  • Therefore the info.xml of the Tasks app now (beside OwnBackup, see above) does also not pass the integrity check. Funny thing is, that the OwnNote info.xml does :D.
  • The new nextcloud store is now implemented, so the adjustment of the store url in config.php is not necessary anymore.

=> But related to Nextcloud itself everything went fine and is working fine so far. Thank you for the great work :smiley: !


Yes and that solved also a problem i had… :relieved:

When i switched from the owncloud apps to the nextcloud apps, i had put in my config.php the line ‘appstoreurl’ => '’,
That caused some errors for some apps not found…
Deleting this line, it now defaults to ‘appstoreurl’ => ‘’, (see difference V0 => V1) and no more errors “apps not found”

too bad… :sweat_smile:
my manual upgrade and migration from owncloud 9.1.2 to nextclouod 11 RC2 went on without errors… :+1:

1 Like

Damn, that’s actually a nice shirt.

Quick q before I go and do a stupid thing like update my 10 install to 11 the day before I go on a 3 week holiday;

Is the collabora situation sorted yet? I was planning on working on implementing that while I was away.

I will document what I can if I have issues. I had some minor issues wiht the webpage updater with >, so expecting some more for the 11.