Who can help me with this internal error after a fresh install?

Good day,

Got a question for the expert community.
Just recently bought a new powerfull and energy efficient server. I am transfering all my services, media and programs from the old to the new server. I had owncloud running. I thought let’s change it to nextcloud. Wanted to do that for some time already.

So I got my fresh installed Ubuntu 20 LTS. Installed nextcloud with snap. Started the install steps. Everything works.
I make an admin account. Log in and everything works…
But then, as many of you will have too: I wanted to change the data folder. So I did with the config file. Moved the old data folder to the new location. Restarted the service…
After that… Instant internal error. But I followed the official data change manual from nextcloud.
Can anyone point me in the right direction?
Many thanks.

Some precise info:

So. maybe you want to tell us the exact error?

Yeah haha I was not so precise I admit. I’m sorry… I was also way to eager to get it solved so I tried and tried and solved it… The problem was that the guide I was following (link above) did not cover the fact that by default the removable-media is not enabled in nextcloud… So after I enabled it with the following command the problem was solved.

$ sudo snap connect nextcloud:removable-media