White Page right after Setup

Right after the Page where i Put in details about admin User and Database. - i just get a blank white page. (with no content (checked sourcecode))
When i relead the page, i start over again with the Setup. - and if i try to create the same admin user again it tells me it exists already.

I checked the database - the user(s) are there. I checked config.php - the information gets written. - it looks to me that it just cannot “finish up” the installation.

  • i tried also with everything on 777 same result…

I downloaded the installation with the web-installer - so permissions and dependencies should be alright.

in apache logs i found
[access_compat:error] [pid 7311:tid 47075414812416] [client ***:46548] AH01797: client denied by server configuration: /home/***/public_html/nextcloud/data/htaccesstest.txt

Wow, i also just tried to Setup Nextcloud just with SQlite - same behaviour…

It seems, that you did install Nextcloud in the folder /home/< username >.

Since the webserver is running with limited access permissions, it may not access the /home/< username > folder.

Same behavior with NC 22…


This user seems to be the standard Webserver User on this server.
Also the home/uname/public_html is the standardpath of Apache. (this stuff all seems to be managed by cpanel)

And if i set the entire nextcloud Folder to 777 - everything and everyone should be able to access it no?

The installation guide might help you with the permissions, specially with owner and group name.


You also should check the config/config.php in the Nextcloud program folder and the nextcloud.log in the Nextcloud data folder.

nextcloud.log says

{"reqId":"YcRRG4TS-HnuxI3pNa-dgwAAAAQ","level":2,"time":"2021-12-23T10:36:11+00:00","remoteAddr":"****","user":"--","app":"no app in context","method":"POST","url":"/4/index.php","message":"Could not detect any host in https:///4/data/htaccesstest.txt","userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0","version":""}

Could not detect any host in https:///4/data/htaccesstest.txt


Either during installation a hostname/domain had been entered as an empty string or the Apache configuration needs some more settings.

You should post your configuration to get a better view to the problem.

here is the config of my last attempt

$CONFIG = array (
  'instanceid' => '*****',
  'passwordsalt' => '*****',
  'secret' => '*****',
  'trusted_domains' =>
  array (
    0 => '*****',
  'datadirectory' => '/home/*****/public_html/nextcloud/4/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://*****/4',
  'dbname' => '*****',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '*****',
  'dbpassword' => '*****',

What did you replace with the asterisk - an IP-address or an URI?
It is recommended to set both in the array:

array (
    0 => 'myhost.domain.tld',
    1 => 'x.x.x.x',

where “x.x.x.x” will be replaced by the IP-address of your Nextcloud server.
So you will be able to call your Nextcloud by IP-address or URI.

What hardware-platform is running?
What operating system and version?
What php-version?
What database is running now and version?
How is what web-server software configured?
Did you install all PHP modules as described in the installation guide - see link below?
Did you do all configurations as described in the installation guide - see link below?

Hey thanks a lot, for pointing to the reccources and questions.

Unfortunatly the system would have to be up by yesterday and i couldnt make it, and il be away for some days now.

I still try to answers questions i know without much diggging: And maybe i investigate futher in some weeks:

  1. It was the URL, i know how the error looks like if it missmatches - i still can try to add the ip as well. (i also access it through the URL)
  2. Its php 7.3 latest
  3. CentOS 7.9 on KVM
  4. MariaDB 10.2.41
  5. I have no idea how exactly the apacheConfig works - i think its done by thirdparty tools (WHM, Cpanel) which i habe limited/no Access to, its not my server other stuff is running there, as i understand there is no proper backup and i dont want to break things…

thank you so much for you help so far!