Where to config reaching URIs in emails Nextcloud server sends?

I have a nextcloud server (just updated to 29.01) working just fine except for the emails it sends. I don’t think I have seen this before so maybe there are new messages in this release. When I get an email from the server, the included URIs are localhost which, as you might guess, isn’t going to work for most use cases. localhost is fine for dropping mail off for delivery on the server but the URIs in the emails need to be the accessible web interface.

Where does that get set? In config.php? Somewhere in the admin UI?

In your config.php with overwrite.cli.url. And this may not be necessary if you make sure that localhost does not appear in trusted_domains (but I’m not sure about that).

  'overwrite.cli.url' => 'http://cloud.paulbeard.org',

this did not work. it seemed like the first thing to try and it broke the config.

What do you mean by that?

the server was 404. It broke.

Strange. That sounds to me like a syntax error in the configuration file. But I can’t imagine how this option can break the server. Is the 404 coming from the web server or from Nextcloud? Can you see something in the nextcloud.log?

that is what it was. I duplicated the default line but didn’t comment it out correctly. Had to look that up this time. Server works, it can send email, now I just need to send with URI so I can make sure that’s resolved.