What is up with the file size in Nextcloud?

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 21.0.1.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 21.04
Apache or nginx version (eg, Apache 2.4.25): AFAIK it’s not enabled
PHP version (eg, 7.4): Same, haven’t installed it yet

The issue you are facing:
File size is not matching the diskspace for storage. Uploading 18 GB worth of files and it takes more than 40 GB of actual virtual drive space

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Put files in the desktop file explorer
  2. Run df -h on server

The output of your Nextcloud log in Admin > Logging:
There’s just insufficient storage warnings.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/snap/nextcloud/current/htdocs/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/var/snap/nextcloud/current/nextcloud/extra-apps',
      'url' => '/extra-apps',
      'writable' => true,
    ),
  ),
  'supportedDatabases' =>
  array (
    0 => 'mysql',
  ),
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/tmp/sockets/redis.sock',
    'port' => 0,
  ),
  'log_type' => 'file',
  'logfile' => '/var/snap/nextcloud/current/logs/nextcloud.log',
  'logfilemode' => 416,
  'passwordsalt' => ###,
  'secret' => ###,
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => ###,
  ),
  'datadirectory' => '/var/snap/nextcloud/common/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '21.0.1.1',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/tmp/sockets/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => ###,
  'installed' => true,
  'instanceid' => 'ocg8jvwcohuo',
  'maintenance' => false,
);

First, you can’t have a working Nextcloud server without PHP and webserver (Apache or nginx) installed and running…

Second, upload is done in chunks that are later combined into files. Those chunks were probably not deleted… Not sure why…

The server is running, but I can’t find the Apache version or PHP version using the server terminal, apache2 and php are not working, unless if there’s another way I can find the versioning of those two let me know. I’m really new to this, experimenting and learning is my whole goal here.

A follow up question, is NextCloud working better with lower granularity files? Is it possible there are too many small files so as you said they’re taken in chunks?

SSH into the system and run php -v and apache2 -v

How did you install Nextcloud?

While installing ubuntu server it gives the option to install a bunch of services and NextCloud is one of them, after that updated the installation and ran sudo nextcloud.manual-install, opened the firewall for NextCloud and the server.

Both of those return command not found.

Then I have no idea how it works… Maybe docker…

Alright thanks nonetheless :slight_smile: