What is the limit to a folder's size? Folder never shows up on clientside

[details=“Support intro”]

Sorry to hear you’re facing problems :slightly_frowning_face:

Nextcloud version : 24.0.6
Operating system and version : Ubuntu 22.04 (server), Ubuntu, Windows, Mac (clients)
Apache or nginx version : Apache
PHP version : 8.x

The issue you are facing:

When uploading a large folder (~55GB, 150k files), the upload seems to work fine, the files show up on the server (web interface) and can be seen in the server’s data folder.
However, none of the connected clients (Mac, Win, Linux, 3.6.1) ever download the folder or its contents. No error message is displayed either (of course the folder is properly selected in the client…). Other folders of fewer files download without problems. A single archive file of the same size (the zipped folder) is downloaded without problems (but unfortunately this is not a solution in my use case).

Storage (both on client and on server) is on SSDs, filesystem on the server is btrfs with hundreds of GB of free space. Clients use a mix of XFS (Linux), NTFS (Win10) and APFS (Mac OS Ventura on M1) with generous free space as well.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it: upload the folder from any client

As I did not find any error messages anywhere, I am not posting any logfiles at this time.

Is there a known limitation for number of files or size of folder? I could not find any such information when searching the web.

I had kind of the same problem with big folders. The windows client had an error message though, it said “The reading of the folder was cancelled due to an error”. No real error message to find anywhere.

I guessed that the server needs too long to list or read the directory, so i upped my Apache and fcgi timouts higher, also increased the php.ini max_execution_time and max_input_time both to 5600.

in /etc/php/***/apache2 and fpm/php.ini:
max_execution_time = 5600
max_input_time = 5600

in /etc/apache2/apache2.conf:
Timeout 1200
ProxyTimeout 1200

and in /etc/apache2/mods-available/fcgid.conf:
FcgidIdleTimeout 1200
FcgidProcessLifeTime 1200
FcgidConnectTimeout 1200
FcgidIOTimeout 1200

That fixed the problem for me. Since then, all bigger folders are synced again to all my clients.

before continue with hardcore troubleshooting review this client setting:


if the limit is crossed, client don’t sync but there is a message as I remember and the user can choose to sync the folder…