Well, this is embarrassing

Still seeing

Well, this is embarrassing, we cannot connect to your document. Please try again.

using NC 11.0.0, Ubuntu 16.04.1 and Collabora.

Strange thing is though, that for some users it’s working.

How can this be user dependant?
No groups are assigned to the collaborative app…

The docker log shows this when the error occurs:

wsd-00027-0031 0:08:55.940637 [ client_ws_0007 ] ERR Error in client request handler: SSL Exception| LOOLWSD.cpp:966

But why would it then work for other users?

Sorry, but I really get the impression that the whole Collabora Office thingy is just not ripe yet.
We are seeing too many people having problems with it.
And weird errors like the one mentioned above.
Using Docker this is supposed to work out of the box.
It does not.
Meaning that I’m fed up with all the

Well, this is embarrassing,


WOPI errors

kind of stuff.
Unfortunately now with 11.0.0 even the documents app no longer works.
So hooray - no longer any online office for me.

There is a new version of the app for Collabora on NC11. Check if you are running 1.1.24, I had to update it manually.

Yeah thanks, I saw that as well.
Why isn’t this version available in the built-in app store?

Or let me ask the other way around:

Why is there a newer version on the nextcloud app store whereas nexctloud is bound to the owncloud app store?
Don’t get it.

So maybe it should just be documented somewhere that

  • Nextcloud
  • Ubuntu 16.x
  • Collabora Office with Docker

together won’t work out of the box.

I know Kay, I had similar (and a lot of) waves of success and failures, joy and (real) anger with each change either of the app or the container or the NC version. Finally I arrived at NC11Final with newest Collabora app and a newly reinstalled docker engine under Debian 8.x (kernel 4.7.x) - and it works…wth!? Please, please don’t ask me why it works, it simply does :wink:

Let’s look at it this way: This is still a beta state - but the devs are working hard on it to finally make it work flawlessly.



what are you awaiting? The whole linux and and open source software world is cobbled by students and hobby programmers where one coder does not know what the other does. Nextcloud developer team: do not take this personally!!

In an uncoordinated software development among endless 3rd party products you can’t await a perfect system for free.

So don’t be embarresed. Just give the developers a bit more time. They’re doing a great job. And emperically you know that you should not update to a .0 for production purposes.



What you are saying is correct and I fully understand that.
But the way that Collabora Office is propagated as an alternative to Office 365 or Google Docs is not correct.

It should be clearly branded as an alternative for people having the resources and the time to tinker around for days, trying to get this to work.

Besides that, I really think it is problematic to hand out a intentionally handicapped version in order to sell hostings of a full version.

This also should be stated when propagating the collabora coffice docker.

But I fully understand that this is open source and that if it doesn’t work it’s my problem.

Hi accolon,

I’m trying to update manually the app for Collabora as I have some errors to make it works.
I get it from this link “https://apps.nextcloud.com/apps/richdocuments” but I do not know how to update my current docker image.

I’m sorry but i’m a beginner with docker.


Hi @Kay,
Cloud you kindly give us a little more info on your reverse proxy setup ? :slight_smile:
It’s kinda tricky to put collabora behind an nginx for example.
do you use full ssl on your nextcloud instance and the proxy to the collabora docker ?
(Maybe you already tried all this, I’m just asking)
Regards, Aal.

@z-obaze : The usual way to update a docker image is to repull it, in this case in an ssh session (as root): docker pull collabora/code

Don’t worry, I spend a lot of time trying to introduce myself to docker, and I just scratched the surface :wink:

The Docker image is independent of this. The Nextcloud app for Collabora belongs into the apps folder inside your Nextcloud installation.

Oh ok, sorry for my misunderstanding.
So, I already have the latest version
Thanks for your answer.


With Nextcloud freshly update to 11, docker collabora up to date, i cannot enjoy it anymore :

Symptoms :

  • with the version 1.1.24, i lost the office icon in nextcloud. (When I resinstall 1.1.14 it comes back)
  • When i try to open a file i got : Well this is embarrassing … and in the docker log “wsd-00026-0031 0:48:38.783170 [ client_ws_0015 ] ERR ClientRequestHandler::handleClientRequest: BadRequestException: Invalid or unknown request.| LOOLWSD.cpp:1171”

I hope it help.

See? That’s exactly what I mean. Sorry to say it, but to put it friendly, Collabora Office is not anywhere near where it should be.

Just look at the collabora category.
It shows that many of us are having trouble with it.

@slapps , don’t worry about the missing icon, you don’t need it anymore with the latest collabora NC app! It simply opens a valid document from the file browser with collabora. Creating a new file is also done in file browser.

Retry new app version and open a file with the browser.



With the latest app version, collabora can be launch but after i get : Well this is embarrassing …

The docker log gives “wsd-00026-0031 0:48:38.783170 [ client_ws_0015 ] ERR ClientRequestHandler::handleClientRequest: BadRequestException: Invalid or unknown request.| LOOLWSD.cpp:1171”


@slapps : could you show us your apache or nginx configuration ?

Please see the link for

Nextcloud.conf : https://paste.ubuntu.com/23668618/

Collabora.conf : http://paste.ubuntu.com/23668612/

For information collabora was working well with this config on nextcloud 10.


Are you in the latest version of Collabora, richdocuments?

if so, have you tried to replace the below line in your apache configuration :

ProxyPass /lool/ws wss://


ProxyPassMatch “/lool/(.*)/ws$” wss://$1/ws


1 Like