/.well-known/caldav & /.well-known/carddav

Hi All!

I have the following 2 issues:

  • Your web server is not set up correctly to find “/.well-known/caldav”. More information can be found in our [documentation↗]

  • Your web server is not set up correctly to find “/.well-known/carddav”. More information can be found in our [documentation↗]

Does anyone know how to fix this?

I used the web installer from the community and are running nextcloud on a web hosting.

Did you read the documentation page about this?

I did but it didnt change anything.

I dont run nextcloud in a subfolder.

I do run it on a subdomain.

I dont use apache i only have it on a ftp server

You sure do use some web server. Likely it is either Apache or nginx. The problem with web hosting services is that especially cheap hosters do not always expose all configuration options to their users. I would consider these web hosting offers unsuitable for running complex web apps like Nextcloud.

Nevertheless, this specific problem should actually be solveable even on a basic web hosting plan, at least if your hosting provider uses Apache. With NGINX no idea, but maybe you can ask your hosting provider or at least tell us which provider and which plan you are using. Maybe someone can help you from there.

I checked and I use Apache. What should i do now to fix the problem?

When i go to https://cloud.example.com/.well-known/caldav it redirects me to https://cloud.example.com/remote.php/dav but I still get the error

The documentation says…

For the first case the .htaccess file shipped with Nextcloud should do this work for you when you’re running Apache. You need to make sure that your Web server is using this file. Additionally, you need the mod_rewrite Apache module installed to process these redirects.


I don’t use any Web Hosting Providers, so I can’t provide a step by step guide. But enabling modules, like the required mod_rewrite module, has most likely to be done via the management interface of your provider, and for Apache to actually use the .htaccess files, the AllowOverride all directive must be set in the VirtualHost config that serves your Nextcloud.


There is no mod_rewrite setting in my php settings…

mod_rewrite is not a php module, it’s an Apache module. On a default Apache installation, on for example Debian, you would enable it using the a2enmod rewrite command.

Ah okay. As you already suspected hahaha i dont have much knowledge about this. When i go to my ftp server, i cant find any directory where my apache settings are and i got no place to enter commands.

You most likely have to change those settings in the web admin panel of the hosting company. What features and configuration options are available, depends of course on the hosting company and the specific hosting plan you are using…

This is my admin panel

Sorry, can’t help with that. But maybe your provider can help or maybe they have documentation on their web site.

Anyone else who can help me with this?