WebUpdater fails updating from 15.0.4 to 15.0.5 with "extracting: can't handle zip file, error code 28" (solved)

Details: see screenshot:

Server settings are reported under https://github.com/nextcloud/server/issues/13639

Anybody any idea how I can solve this issue?

First of all u can restore from backup …“data/updater-ocv0rvsiybom/backups/nextcloud-15.0.4.0/*”…
I use ‘cp -ar’ so u get no permission problems.

nextcloud is the worst software i have ever used. Would be nice if they will create a real v1.0. 15.???.??? is more like 0.15b.

If u get an solution, it would be nice to share it with us.

Lg Maik

1 Like

Did you install the php-zip module?

2 Likes

sorry for my late response.

Maik_Garbade: this is a “lucky error” since the error occured before entering maintainance mode. So my old installation is still running without doing anything.

peteman52: thanks for this input. You solved my problem. I did a

sudo apt-get install php-zip
sudo service apache2 restart

After that web updater succeeded. Many, many thanks!!!

Does not work for me:

  • Current version is 18.0.2.
    Update to Nextcloud 18.0.3 available. (channel: “stable”)
    Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-18.0.3.zip
    Open changelog :arrow_upper_right:
    Retry update

  • Check for expected files

  • Check for write permissions

  • Create backup

  • Downloading

  • Verifying integrity

  • Extracting

Can’t handle ZIP file. Error code is: 28

20:19:56 [~]-> sudo service apache2 restart
Failed to restart apache2.service: Unit apache2.service not found.