Website "Start Update" button not doing anything, hosting with cPanel so no SSH access

25.0.3 upgrading from some version of 23.
Apache or nginx version (Sorry I don’t know)
PHP version: 8.1 (can switch to 7.4 or 8.0 if needed)

Steps to replicate it:

  1. Open my hosted NextCloud site on my domain
  2. Click on the Start Update button

Nothing happens. I’ve clicked it a couple of times and pressed enter to make sure it’s clicked and left it overnight to make sure it isn’t just working slowly in the background, but no results thus far.

I’m not too versed in the ways of web hosting, I run a fairly cheap host with Krypton Networks (because I got grandfathered in at a really cheap rate)

They use cPanel and I installed NextCloud using the Softaculous app installer, I’ve never seen it before but it just worked and has worked, so I haven’t minded using it.

All has been well, as I usually just click update on Softaculous and it’ll update everything just fine, has been for a couple of years now. However, the start update button no longer seems to work. I understand that there is a suggestion to use SSH to manually start an update, but I don’t have permission it seems to do this with my current host.

Does anyone have any suggestions on some troubleshooting and additional details I may need to dig up so I can get this resolved?

Thank you in advance :slight_smile: