WebDav unusable

Nextcloud 15 RC 2
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): nginx 1.14.1
PHP version (eg, 7.1): PHP 7.1.24

The issue you are facing:
WebDav is practically unusable for accessing my files. Tried in MacOS using Finder and ForkLift. Performance is very slow. Transfers fail when trying to copy more files at once.
The server is not showing any excessive system load when performing WebDav operations (DB is not choking, CPU is load is OK, memory is free).
I am using the memcached extension.
I also tried the mobile and desktop sync apps, both work fine.
I first tried with NC14 and now I am trying out NC15 but things are still the same.
I don’t know what could be wrong.

The logs are not showing any errors.

Here’s my config.php:

$CONFIG = array (
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'instanceid' => 'xxxx',
  'passwordsalt' => 'xxxx',
  'secret' => 'xx',
  'trusted_domains' => 
  array (
    0 => 'xxxx',
  'datadirectory' => '/var/www/xxxx',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'xxx',
  'dbname' => 'nextcloud_db',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'nextcloud',
  'installed' => true,
  'updater.release.channel' => 'beta',
  'mail_from_address' => 'nc',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => 'xxxx',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'updater.secret' => 'xxxx',

Have you tried cyberduck? The native implementation is known to create a lot of requests and probably performs not very well. Was this different in NC14? When you see a sudden change between the stable current version and the release candidate, you can directly create a bug report on https://github.com/nextcloud/server/issues

OK I tried Cyberduck and it works OK. However then I don’t have the filesystem mounted as network drive. Do you know whether there is any way to mount it under MacOS that would actually work?
Thank you.
Btw. the behaviour was the same using NC14.