WebDav for NextCloud 10 not working


After upgrading form NC 9.0.53 to 10.0.0, I am expiriencing problems when connecting via WebDav.

With NC 9.0.53, I could successfully connect from a Windows 7 computer by using Windows native Webdav functionality (simply mapping the webdav url to a drive letter, and “on connecting” provide user credentials). This worked well, although a bit slow in certain circumstances.

Now, after upgrading to NC 10, the connection is no longer possible (I am getting windows error " 0x80070043 network name not found"). The cloud server uses LetsEncrypt certificate for SSL.

What puzzles me, is that the server suggests to use:
as a webdav address, but in the online documentation https://docs.nextcloud.com/server/10/user_manual/files/access_webdav.html
two different addresses are used, either the “/remote.php/webdav” one or “/remote.php/dav/files/USERNAME/
(by the way, I tried both of them, with no success)

this seems to be inconsistent, but I might misunderstand something here…

I am not sure whether this topic below is related to my own issue:

I’m having exactly the same issue and am equally confused by the documentation.

Looking at the logs with davfs debugging enabled, it seems like webdav is currently broken in Nextcloud(?), as requests simply timeout and die.I get a lot of these:

Aborted request (-2): Could not read status line
Request ends, status 0 class 0xx, error line:#012Could not read status line: connection timed out

davfs2 is otherwise working fine, picking up the URLs and using my secrets file.

The really weird thing is that this worked on my initial install of nextcloud (migration from latest Owncloud) last week, but now seems to have broken down for no reason I can point to…

I have exactly the same problem. Also I use letsencrypt ssl certificate.

You can add me too in that list. Windows-Webdav won’t connect with the error above. The Total Commander Plugin works.

If it is the same bug, you need to get the user-agent-string of the windows explorer (check the access-logfile of your webbrowser). If you have the string, you can try to add it here (you need to apply patch #1328 in combination with #797 before):

I this works, create a pull request to add this user-agent-string to the exception list.

I don’t think so - my problem comes from trying to mount using standard linux mount. This has worked flawlessly for a long time on both owncloud and nextcloud. Until now.

I’m not doing it from Windows or OSX, but locally on the nextcloud server (Ubuntu). As far as I know, this is the “best behaved” webdav client there is…

@tflidd : I dont belief this is the “same bug”, because my configuration actually did work before the upgrade to NextCloud 10, so the “user-agent string” must have been known before (or am I misunderstanding something?)

but anyway, my “user-agent string” currently is:
"Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0"
however, this is only true for this machine of course. If I would login from another computer, there would be another “user-agent string”. It certainly is impossible to keep track of all these strings (with every browser update, the string changes). So “adding these strings to the server-software” is simply impossible.

Sorry, I need a different solution I am afraid
Thanks, Ruediger

I should add that I ran the litmus tests (WebDAV checks) on the installation. 30 tests in total of which 28 passed and two failed. I don’t know if this is relevant, but I thought I’d add the errors:

  1. prophighunicode… FAIL (PROPPATCH of property with high unicode value)
  2. propget… FAIL (No value given for property {http://example.com/neon/litmus/}high-unicode)

Seems both failed tests relate to how the Nextcloud dav client handles unicode. Again, not sure if this is relevant, but thought I’d add it.

@Schultz-IT-Solutions : there were new security features in NC 10. Have a look at this topic and the information gathered to debug this problem: https://github.com/nextcloud/server/issues/223

Do you get the same errors?

Thanks tflidd for your answer, but my problem seems not SSL related (if it was, I belief I would receive some kind of “connection not possible” message - but then again, maybe not…)
However, the only “reply” I am getting when trying to connect is (as mentioned before) a “Network name could not be found”. (I tried this with both http and https on the URL https://cloud.mydomain.com/remote.php/webdav/ ).

And I still would like some clarification on the actually needed URL for “WebDAVing”, as the doc is inconsistent here…

And I successfully tried the “Synchronisation” (using the WINDOWS desktop client Version 2.2.3 (build 4) ).
So this works, and also the “WebInterface” works.
Only “WebDAV” access is NOT working.

Sorry, I did a copy&paste error, I updated the link

I now successfully updated to 10.0.1, but still cannot connect through Webdav.
There is no error message I can find and no hints at all.
I really need this to work in order to use NextCloud (or do you suggest I should downgrade to 9.0.53 again?)

NC 9 would be a workaround but we want that to work in NC 10 as well. The best is probably to open a new issue on github and to provide an unencryted traffic dump of what your client is sending as well as your webserver logs.

Has this issue been figured out?
I am new to using NextCloud but am experienced with programming.

I just finished setting up NextCloud ( 10.0.1 ) on Ubuntu 16.04 and all seems to be working well.

I am using letsencrypt with no issues.

I just installed NextCloud on my Andriod phone ( Galaxy S5 ).

I also installed DAVdroid from the Play Store.

I added account in DAVdroid but not able to get a sync, however there is a session show in NextCloud Personal/Sessions DAVdroid

Ok, It works now.

I removed account from NextCloud on my Android.

Removed account from DEVdroid on my andorid.

Added Account back on NextCloud android app.
In Setting of NextCloud android app clicked on Setup calendar & contacts sync
Added account via Login with URL and user name
URL format https://mydomain.com

Clicked Login at which point I got a permission notification from DAVdroid in my notifications.

I opened the notification and gave permissions to Calendar, Contact and Task.

I opened DAVdroid and set the CardDAV and CalDav options.

In my Contacts I checked Accounts and DAVdroid was displayed.
With my All Contacts displayed I Click the Menu and choose Contacts to display
I set it to custom and added my NextCloud account set in DAVdroid.

I opened Google Calendar and added a new event for my NextCloud Calander and all worked fine.

for windows7 users: try to start the service “WebClient”, then it should work.
see also https://github.com/owncloud/core/issues/26350

as an alternative i used the Netdrive 1.3.4 (last freeware version) to mount the nextcloud10 as windows drive which works for me too.