Webdav credentials

CPU: AMD FX-8370 Eight-Core Processor

Memory: 8.7 GB


Version: 7.3.17

Memory limit: 512 MB

Maximum execution time: 3600

Maximum upload size: 16 GB

Nextcloud 18.0.4

i am trying to connect the notability app to my nextcloud via webdav … using the link that gives me my nextcloud and as credentials i use my normal access credentials.

notability tells me that my credentials are wrong and i don’t understand why.

I use Two-Factor Gateway … can that be the problem?

Yes indeed, that is most likely the problem. Please generate app specific passwords if you want to access shared contacts, calendar or file data. You will find this function under Settings > Personal data > Security > Devices & Sessions.

1 Like

Thank you !!

if you can still help me out.

is it possible that the webdav has upload rules?

because if I ask my noteability to save the file as a pdf the upload fails.

if I have it saved as a .note file the upload is perfectly successful

Uploading a file to a folder which you own (not shared to you in read-only mode) should instantly work as long as you’ve successfully established an authenticated connection. Nevertheless you can only write data to a directory, if the user under which your web server is running, e.g. www-data or wwwrun, is allowed to access this directory path. So you have to make sure that access has correctly been granted.

If you use the search function of this forum, you will find several similar requests and in most cases the underlying access rights had to be adjusted/corrected.

The provided screenshot indicates that you’ve tried to upload a file to a public share? If yes, you can set individual access rights to upload files to it using a web browser. If you personally want to upload files to one of your own folders you have to make sure that authentication has succeeded.

I have not understood well … up to now I have not had any concession problems … is it strictly connected to the webdav?

and then because from problems with the pdf and not with the .note … if it were an authorization problem not even the .note would be loaded

It seems that you haven’t established an authenticated session to the server, so that you cannot upload a file. Can you please describe in detail how you’re accessing your server. Which tool/program are you using etc.?

Sorry, I don’t understand what you want to tell me. Please be more precise and describe in detail what you’re doing in which order, using which tools etc.

Unfortunately I don’t use an iPad and therefore cannot help you on this topic. I would normally have expected that you use the Nextcloud app on an iOS device to sync files with a server instead of using a direct access.

I get it. Thanks.

The next app that I ran perfectly

What was the root cause of the problem? Please share your experience so that other users can use that information too.

I don’t know the cause, simply uploading to the cloud via the notability app doesn’t end if you save in pdf format and it works if you save in .note

I think I found something.

I think it doesn’t load files larger than a certain size. it’s possible?
I noticed that after a big modification not provided, even the .note file was loaded (before it happened) is it possible in your opinion?

the usual identical problem is given in the registry … so I suppose it depends on the size of the files being uploaded