WebDAV connection error using 3rd part app

I am getting an error when I try to connect the android app “SMS Backup & Restore” with my nextcloud server (tab.digital). The server URL I am using is:

Username is correct
Password is correct
Folder path is correct (although I don’t have permission to create or view folders on the nextcloud server from the app itself)

The error message states that there was an “error received while trying to contact…” and then it shows the server path above

I tried giving this app its own password, and it still doesn’t work. What could be the issue

should you not use


1 Like

This does not work either, I had tried this. I get a 401 error no matter what I try.

I used https://wim.nl.tab.digital/remote.php/dav/files/USERNAME/ (username replaced with full email address)

and get this error "Error received while trying to contact https://wim.nl.tab.digital/remote.php/dav/files/USERNAME/webdav(401)

The HyperText Transfer Protocol (HTTP) 401 Unauthorized response status code indicates that the client request has not been completed because it lacks valid authentication credentials for the requested resource

somewhere your credentials are not send or verified correctly.

for example I use a external app to connect to webdav when I enter my password special characters like !@#$_& and view the apps source where the password is saved unencrypted I see that those special characters have been stored as %40 for @, %23 for #, %24 for $ etc.

so when using the username user@name.example
with password H3!!o@2

my connect url would show davs://user%40name.example:H3!!o%402@cloid.domain.tld:443/remote.php/dav/files/user@name.example/Share

but as you stated already you tried a app password which does not contain special characters so this information is useless.

I only notice that I connect to davs:// not https:// does this app you use support webdav protocol?

It does indeed… here is the app I am referring to…they also do not know why this is occurring. I am currently using nextcloud one, but may upgrade to my own server with tab digital


im actually having the same issue with simpletask. Any apps that allow me to use the nextcloud file app to sign in have no issue, it is only when I am required to type the server path and enter username and pass

then I can assume you use the payed pro version as the free version does not support webdav.

just to verify as you have not mentioned it.

I am currently using a paid version…I am using nextcloud one…however I am going to upgrade to private cloud so I can run apps

There must be an error in the path I am typing in…because there is no ability on the web portal to approve or reject certain apps

when you enter the server URL to use do you enter https:// in yourself or is it preset.
maybe there is a dropbox or selection where you can change that to davs://

you freely type, there is no preset or dropdown…your saying to try


and what after this?

like your url


The test failed with the error: Expected URL scheme ‘http’ or ‘https’ but was ‘davs’

I think that the request to login is getting rejected serverside. Maybe this app/software is only designed to access a local/self-hosted server, as opposed to a cloud-hosted one?

@git_warrior I just tried setting this up and had the same issues. You can however use the local storage option then save to Nextcloud via the app. This will do everything you need and the paid app would then only be needed for encryption, compression and supporting the developer.