webDAV bug in logging

Dear folks,

I am still having constant errors in my log about web dav.

Is anybody able or willing to digg into this?

Here is the thing:

NC 11.0.1
hosted enviroment
all webdav clients seem to run smoothly
error didnt occur in log with NC 10.x

error message showing in log (server info redacted):

Sabre\DAV\Exception\Forbidden: HTTP/1.1 403 Forbidden
/XXXXX/adress/server/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 773: OCA\DAV\CalDAV\Calendar->propPatch(Object(Sabre\DAV\PropPatch))
[internal function] Sabre\DAV\CorePlugin->propPatchNodeUpdate(‘calendars/alexa…’, Object(Sabre\DAV\PropPatch))
/XXXXX/adress/server/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/XXXXX/adress/server/3rdparty/sabre/dav/lib/DAV/Server.php - line 1241: Sabre\Event\EventEmitter->emit(‘propPatch’, Array)
/XXXXX/adress/server/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 385: Sabre\DAV\Server->updateProperties(‘calendars/alexa…’, Array)
[internal function] Sabre\DAV\CorePlugin->httpPropPatch(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/XXXXX/adress/server/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/XXXXX/adress/server/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method PROPPATC…’, Array)
/XXXXX/adress/server/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/XXXXX/adress/server/apps/dav/lib/Server.php - line 227: Sabre\DAV\Server->exec()
/XXXXX/adress/server/apps/dav/appinfo/v2/remote.php - line 30: OCA\DAV\Server->exec()
/XXXXX/adress/server/remote.php - line 165: require_once(’/XXXXX/adress…’)
{main}

1 Like