WebDav: Benutzerauthentifizierung funktioniert nicht

Moin.

Ich bin Neuling, was das Thema “Nextcloud” angeht. Wahrscheinlich ist die Lösung simpel, aber alle bisherigen Versuche sind bereits schief gegangen.

Ich versuche, einen Nextcloud Share mit WebDav in eine Windows 10 Umgebung einzubinden. Das Ganze klappt weder per Explorer (“Netzlaufwerk verbinden”) noch via CLI (“net use U: https:// …”). Als FEhlermeldung kommt “Der angeforderte Vorgang konnte nicht durchgeführt werden, da der Benutzer nicht authentifiziert werden konnte”. Da ich im CLI ja sowohl USername als auch Passwort in Klartext sehe, ist ein “Fingertrouble” auszuschließen.

In der Registry ist “AuthForwardServerList” sowohl mit IP als auch mit URL gesetzt.

Konfiguration:
Nextcloud 19 läuft auf einer Ubuntu LTS Installation (Installation via Snap), der Client ist ein normaler Windows 10 Rechner. Beide Systeme im selben LAN.

Der Zugriff von Windows auf die NExtcloud Installation via NextCloud Client funktioniert tadellos.

Hat jemand einen Tipp, wo das Problem liegen kann?

Vielen Dank im Voraus
L.

Ich habe jetzt wohl eine Lösung gefunden:
Da sowohl der Server als auch der WebDav-Client im gleichen LAN sind, habe ich die IP-Adresse des Servers angegeben. Jetzt habe ich es mal mit dem Domainnamen versucht, den der Server über das MyFritz.net Konto erhalten hat, und sihe da, es klappt mit der WebDav-Anbindung. Ist mir zwar nicht ganz klar warum, aber es geht jetzt.
Hat jemand dafür eine Erklärung?

1 Like

Hi, hatte bis eben da gleiche Problem wie du. Bei mir lag es daran, dass man ein In-App Passwort in Nextcloud generieren muss. Vielleicht hilt es dir ja auch weiter.
Grüße,
H.