Webdav and Windows - no automatic share-mapping after reboot/logoff in spite of successfully stored credentials

Hi,

using webdav in order to map my NC-shares to deviceletters in the Windows explorer generally works for me.

But there is still a problem which is a little bit strange: If I save the share-credentials by windows using the “remember my credentials”-option, they are actually successfully stored in the windows safe so everything seems to be fine. But after logoff or reboot there is no automatically reconnection. The credentials are saved, but every time if I click on the mapped deviceletter (with a red-marked “X” because of not-connected status) in the windows explorer, the windows credentials-prompt appears again. Fortunately I dont have to type in the credentials again, but I have to confirm by clicking on OK in order to reconnect every time.

connect

Windows uses the service “webclient” for webdav. There are tutorials to edit two webclient-parameters in the registry in HKLM as follows:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
“BasicAuthLevel”=dword:00000002
“AuthForwardServerList” => set a multi-reg key with your domain here <=

But the problem still exists. I tested it in Windows 7, 8.1 and 10 (different editions). The result is always the same: The registrykey is not the solution here.

Fortunatlely the “net use”-CMD works fine in this matter. But I am also interested in a GUI-solution in order to be freed from the prompt window. Is there a solution? Did anybody achieved to get rid of the prompt?

:slightly_smiling_face:

Unfortunately AuthForwardServerList is useful only for Windows/NTLM Authentication, when you use (as is your case) basic authentication AuthForwardServerList won’t work, that’s why you get prompted for your user and password again.
See Notes of https://support.microsoft.com/en-us/help/943280/prompt-for-credentials-when-you-access-webdav-based-fqdn-sites-in-wind

" If you have added the AuthForwardServerList registry entry, be aware that if Basic authentication or Digest authentication is implemented in the network, using the registry entry cannot prevent the prompt for credentials"

Hi,

thanks for your information.

I have to add that also with “BasicAuthLevel”=1 it did not work.

Is there a way to set/change another registrykey or change NC-server-config in order to get rid of the prompt?

:slightly_smiling_face:

It doesn’t matter whether you use http or https with Basic Authentication (be aware! use it in http an everyone will be able to sniff traffic and see your credentials!)
The problem is about Basic Authentication, you’ll always get the prompt!

So there is no technical way to get rid of the prompt? I dont understand it, because with “net use”-command and credentials given in the CMDlet it works fine at once without the need of credential-confirmation as in the GUI.