WebDav and CalDav not connecting to server

As the title states, I am having trouble getting CalDav and WebDav to work on my client PCs. I can successfully do this with the GNOME 3 desktop using the online accounts feature and selecting ownCloud. However with Dolphin in KDE plasma 5.6 and macOS Finder I get the errors:

"There was a problem connecting to the server “example.com
Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.”

I have followed the documentation with no success.

Raspberry Pi 3
Connection via ethernet (wireless disabled), with a static internal IP and set up in the DMZ.
Current image of Raspbian Jessie and Nextcloud 9, Apache2, PHP5, MySQL
Connection is also encrypted from the server using a cert from Let’s Encrypt
Also using DuckDNS for dynamic DNS service

When I enter the WebDav/CalDav information I use the info given to me from Nextcloud

Just to make sure… I had this error message once, too and it turned out to be a price with the Android app rather than owncloud. Have you checked, the app can sync others data alright?


Hi John, I’m syncing straight from my file managers (KDE Dolphin and macOS Finder), not the app. Is that what you’re referring to, or some other application?

If this helps, here’s the output I get when I check my log:

Exception: {“Message”:“HTTP/1.1 401 No ‘Authorization: Basic’ header
found. Either the client didn’t send one, or the server is
[internal function]:
call_user_func_array(Array, Array)\n#2
Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)\n#3

If I’m seeing this right, it’s only trying to connect via HTTP right? If that’s the case then that would be the problem, because I have my server configured to force HTTPS for everything and all HTTP requests to be redirected to HTTPS

So I found some new information. For some reason it is blocking webdav access to only 1 of my users (which is the one I am using). Worked like a hitch for my admin and family account in Dolphin. So why would it be blocking one of my users? Is there a limit to how many times I can connect an account to a device? Currently I have CalDav on my iPhone and Thunderbird on Kubuntu, as well as WebDav on my Fedora 24 GNOME install

I solved it! This is also very dumb too. For some reason, this user is the only one that it decided to capitalize the first letter of when doing WebDav


Glad to hear you were able to solve it on your own.

Thanks for bothering to share the solution. Much appreciated!!