Web updater triggers server block

Nextcloud version (eg, 18.0.2): 12.0.13
Operating system and version (eg, Ubuntu 20.04): CentOS 7
Apache or nginx version (eg, Apache 2.4.25): 246 (-93)
PHP version (eg, 7.1): 5.6.40

The issue you are facing:
I’m trying to update from RPM-based 10.0.4 to source-based current. I copied my data and database to a new CentOS 7 host and managed to get it working with 10.0.4. I had to manually update to latest-11 but was offered the option to update to 12.0.13 on the admin page. However, while the automated updater was running I got the following error:

"We noticed that you request many releases once every hour which stressed our download server quite hard. We blocked access for you for now. To resolve the issue and maybe improve the download scripts you can reach out to the Nextcloud team."

I waited overnight and tried again, with the same result so I manually finished the install of the base software in /var/www/nextcloud and re-started the web server. Upon being presented by the update screen I said to update. It mostly worked but at the end I was presented with:

"Repair warning: Could not install core app bundle: Could not download app bruteforcesettings"

I presume the second error is directly related to the previous one. It says to reach out to “the Nextcloud team.” but doesn’t give any indication how best to do that so I’m posting here in hopes of reaching the right people who can unblock my access.

My new plan is to manually do the source installs from here on out but I still need to do the app updates for each level.

I should note this is a trial-run for the update. I have to get all the way to 20 (lots of downloads to go) and will then need to do it “for real” once I’ve figured out all the ways I can mess it up.

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

  1. use the automated updater

The output of your Nextcloud log in Admin > Logging:
(It’s been sitting and spinning on this for about 20 minutes. I think it might not ever come back. I presume I can find the log file somewhere and grab the text directly if that’s needed.)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'maintenance' => false,
  'log_type' => 'syslog',
  'updatechecker' => true,
  'check_for_working_htaccess' => false,
  'asset-pipeline.enabled' => false,
  'assetdirectory' => '/misc/nextcloud',
  'preview_libreoffice_path' => '/usr/bin/libreoffice',
  'tempdirectory' => '/misc/nextcloud/tmp',
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/var/www/nextcloud/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/misc/nextcloud/apps',
      'url' => '/apps-appstore',
      'writable' => true,
    ),
  ),
  'instanceid' => 'redacted',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' =>
  array (
    0 => 'redacted',
    1 => 'redacted',
  ),
  'datadirectory' => '/misc/nextcloud/data',
  'overwrite.cli.url' => 'redacted',
  'dbtype' => 'mysql',
  'version' => '12.0.13.2',
  'dbname' => 'nextcloud',
  'dbhost' => 'redacted',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'oc_nxadmin1',
  'dbpassword' => 'redacted',
  'logtimezone' => 'UTC',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_domain' => 'redacted',
  'mail_from_address' => 'redacted',
  'mail_smtpmode' => 'php',
  'theme' => '',
  'loglevel' => 2,
);

The output of your Apache/nginx/system log in /var/log/____:
(evertything there pre-dates the download error, nothing relevant I can find)

FTR, it looks like the blockage went away of its own acord. I waited several hours and tried the next step. I was able to upgrade to 13.0.12 without problems.

I’m going to continue with the manual software install process to 19 for now.

nomad