Web updater issues (plural!)

Just updated a Nextcloud Server (Apache) installation from v27.1.1 to v27.1.2 via web updater. The first thing I noticed was that four files were classified as ‘extra’, although they are part of the original installation package: package-lock.json, package.json, composer.lock and composer.json. Also, the entire dist directory has been categorized as ‘extra’ for some time now, but is included in the installation package as well.

What really gave me a headache today was the warning message after the update:

“Your web server is not properly set up to resolve “/ocm-provider/”. This is most likely related to a web server configuration that was not updated to deliver this folder directly. (…)”

However, it turned out that this was not a configuration error at all, but that the ocm-provider directory is no longer included in the v27.1.2 installation package (it was still in v27.1.1 though)!

Looks like the check routines of both the web updater and the post-update check in the ‘Security & setup warnings’ section of the administration overview could use a revision.

For the time being, I have manually restored the ocm-provider directory from the v27.1.1 package because I couldn’t find any other solution in a hurry. But: can this lead to problems?

Thanks for any reply.


I also have this problem, but have left it be…If someone can explain to me how to restore the missing directory, I’d be grateful

I have the same problem, can you explain the restore process?

I found it by wandering around the forums
I am using ubuntu linux
Download and extract the file 27.1.1 to a home directory.
Drop into a shell
sudo mv /home/extracted file/ocm-provider/ var/www/html/nextcloud/ocm-provider/

But PLEASE check first before you do anything that might break your system

I have done the same, and restarted apache2…didnt make a blind bit of difference…Did you solve the problem?

@egglestn, @mahdi.7839 I manually created the directory ocm-provider and the single file index.php in it as user ‘www-data’, opened the latter in the editor, then simply copied and pasted the few lines of PHP code from the index.php of v27.1.1 and saved the file.

After restarting Apache the warning message was gone.

@egglestn Could the problem on your side be that the ocm-provider directory and the included index.php have the wrong ownership (namely ‘root’)?

The real question, however, is why the warning message appears in Nextcloud at all when the directory in question is no longer provided in the official download package. Is this now an error in the delivery or rather in the test routine?

I tried that , and sadly, it didn’t work. I downloaded a full version of 27.1.1 and copied the relevant files over

However by tweaking the .htaccess file as suggested here

the problem went away…
I don’t have the expertise to say why one worked when the other didn’t, and certainly permissions have been the source of 80% of all problems in Nextcloud… In any case, alls well that ends well…
thanks for the help