Web updater doesn't work

Hi folks,

some time ago I moved from OwnCloud to NextCloud, because updating OwnCloud most of the time ended up in crashing my installation. Unfortunately NextCloud doesn’t seem to do much better :frowning:

Currently I’m running NextCloud 13.0.0 on my Debian 16.04 server.
Now I got a message (at the top right) that NextCloud 13.0.7 is available. By clicking the message I’m sent to the settings page and click “open updater”.

The following is shown at the updater page:

√ Initializing
Current version is 13.0.0.
Update to Nextcloud **14.0.3** !?  available. (channel: "stable")
Following file will be downloaded automatically:     https://download.nextcloud.com/server/releases/nextcloud-14.0.3.zip
√ Check for expected files
√ Check for write permissions
√ Enable maintenance mode
√ Create backup
√ Downloading
√ Verifying integrity
√ Extracting
√ Replace entry points
√ Delete old files
√ Move new files in place
√ Keep maintenance mode active?
√ Done

When I click “Continue Update” a new button appears at the bottom of the page stating: “Go back to your Nextcloud instance to finish the update”

When I click that button I’m sent back to the NextCloud start page with the message at the top that there’s an update available to NextCloud 13.0.7.

The error logs says:

  Error PHP Zend OPcache can't be temporary enabled (it may be only disabled till the end of request) at Unknown#0

I don’t have PHP-Memory-Cache configured. Is that a problem?

The output of my config.php file in /path/to/nextcloud

<?php
$CONFIG = array (
'instanceid' => 'oclz2x6dbk6h',
'passwordsalt' => 'XXXX',
'secret' => 'XXXX',
'trusted_domains' => 
array (
  0 => 'nc.XXXX.de',
),
'datadirectory' => '...../nextcloud/data',
'overwrite.cli.url' => 'XXXXX',
'dbtype' => 'sqlite3',
'version' => '13.0.0.14',
'logtimezone' => 'UTC',
'installed' => true,
'loglevel' => 2,
'maintenance' => false,
'theme' => '',
'updater.release.channel' => 'stable',
'updater.secret' => 'XXXXXX',
);

Besides of the missing Zend OPcache: Why are there so many version numbers? The updater says 13.0.7, config.php says ‘version’ => ‘13.0.0.14’ and the updater wants to 14.0.3

When I enter the updater page I get the following message in the Apache log:

AH01630: client denied by server configuration: /var/www/vhosts/XXXX.de/nextcloud/data/.ocdata

For testing purposes I set nextcloud/data and nextcloud/data/.ocdata to worls read-writable with no avail.

The .htaccess file in the data directory looks like this:

# Generated by Nextcloud on 2018-02-28 14:29:48
# line below if for Apache 2.4
<ifModule mod_authz_core.c>
Require all denied
</ifModule>

# line below if for Apache 2.2
<ifModule !mod_authz_core.c>
deny from all
Satisfy All
</ifModule>

# section for Apache 2.2 and 2.4
<ifModule mod_autoindex.c>
IndexIgnore *
</ifModule>

What can I do?
Is there a save way to export all the data, delete and set up Nextcloud completely new and import the data again?

Problem is solved.
I gave it up and did a manual upgrade. After lots of errors it finally worked out. Pretty disappointing, though to spend three hours each time an update is out, and always in fear that my data are lost in the end.
I might as well have stayed with owncloud. :frowning:

Would be nice if there where a simple export-import feature to backup my data and restore them in the new installation.
Anyway, thanks for the free product. It only costs my time.

I do manual upgrade much quicker.

For the updater app, I prefer to use it via terminal to avoid timeouts and other restrictions for php. In the Nextcloud main folder, you just execute:

sudo -u www-data php updater/updater.phar

Often in the end I need to do one more sudo -u www-data php occ upgrade because for some reason not everything finishes or at least the maintenance mode is enabled again.

Now for your error: With the OPcache error should only be a warning, that the script stops should be a bug you can report at the repository: https://github.com/nextcloud/updater

So it seems you have 13.0.0 installed, if you are on the stable release channel, it will get you the latest stable which is currently 14.0.3. If you prefer to stay with 13.0.x-branch and install 13.0.7 you can switch into the production release channel (https://nextcloud.com/release-channels/). The full version number has a forth digit (like your 13.0.0.14), I’m not sure about the real origin, it is sort of internal number which has no importance for end users. Could be that the beta-test-versions had a lower version of this.

I see that you are using sqlite. This is not recommended and should only be used if you have no real database available for performance reasons.

Thanks for your hints, tflidd. Next time I’ll try it that way.

I’m aware that sqlite is slow, but as I am pretty much the only one using this NextCloud instance (mainly for synchronization of contacts, calendar and some photos/files) sqlite is absolutely sufficient.