Web update from 13.0.0 to 13.0.1 remains in maintenance mode

I tried to update Nextcloud version 13.0.0 to 13.0.1 via the web interface.
Everything seemed to go smoothly, until that I had to reload Nextcloud.
However, now I get this message:
“This Nextcloud instance is currently in maintenance mode…”

Any suggestions what could be wrong and how I could fix it?

I tried to use this command (I’m on a Synology box):
sudo -u http php70 ./volume1/web/nextcloud/occ maintenance:mode --off

I get this error message:

An unhandled exception has been thrown: Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occured in driver: could not find driver in /volume1/web/nextcloud/lib/private/DB/Connection.php:64

Find full stack trace here.

Maybe this GitHub issue is related.

I don’t think that it is related because for the linked issue, the database connection times out but you can’t establish one in the first place. Perhaps the database modules (pdo_mysql) in the command-line php are not enabled.

Check if such a module is loaded:
sudo -u http php70 -i | grep pdo

If the output is empty, you must check the configuration files which can be found at:
sudo -u http php70 --ini

If you want to disable the maintenance mode only, you can as well edit the config/config.php and change the maintenance-variable to:
'maintenance' => false,

Thanks @tflidd!

Indeed, apparently the pdo module is not installed when using php70 from the CLI.

I manually set 'maintenance' => false in config/config.php as you suggested.

When I accessed Nextcloud in the browser after changing this setting the update was triggered again, and went smoothly. Everything seems to work fine again.

1 Like