Web Installer gives rename error

Trying to install remotely.

I’ve copied setup-nextcloud.php to my hosted domain root.
I’ve given it 777 permissions.
I’ve opened it in my browser. (https://hosteddomain.uk/setup-nextcloud.php)
I click next.
I see “All Nextcloud dependencies found”.
I accept the default folder. (nextcloud)
I get Warning : rename(tmp-nextcloud1521833238/nextcloud,./nextcloud): No such file or directory in /home/www/hosteddomain.uk/setup-nextcloud.php on line 166

I don’t see a nc.zip. Should I? Also no extract folder. Could it be a permissions issue?

I installed ownCloud a few years ago and did have a few issues with that, but got it working without too much grief.

All help gratefully received. :slight_smile:

You are sure that you didn’t add a comma and point by accident?

The installer script only downloads the archive and extracts it. In some cases, the security settings could prevent scripts from downloading files, so you can try to download the latest archive (https://nextcloud.com/changelog/#latest13), extract the files and upload them on your webspace.

Very certain I did change anything. Next I tried creating a nextcloud folder and moving the php file into it. Then I ran it again and gave . as the path. That gave these errors.

Warning : scandir(tmp-nextcloud1521900488/nextcloud): failed to open dir: No such file or directory in /home/www/modernharbinger.uk/nextcloud/setup-nextcloud.php on line 161

Warning : scandir(): (errno 2): No such file or directory in /home/www/modernharbinger.uk/nextcloud/setup-nextcloud.php on line 161

Warning : array_diff(): Argument #1 is not an array in /home/www/modernharbinger.uk/nextcloud/setup-nextcloud.php on line 161

Warning : Invalid argument supplied for foreach() in /home/www/modernharbinger.uk/nextcloud/setup-nextcloud.php on line 161

Warning : rmdir(tmp-nextcloud1521900488/nextcloud): No such file or directory in /home/www/modernharbinger.uk/nextcloud/setup-nextcloud.php on line 164

Now I’ve uploaded the install zip and am unpacking it manually…

And another problem.

When running index.html to complete the setup, I get the following.

Error while trying to create admin user: An exception occurred while executing ‘CREATE UNIQUE INDEX personal_sections_class ON oc_personal_sections (class)’: SQLSTATE[HY000]: General error: 14 unable to open database file

Next option? I’ve tried everything that I can think of to give it access to the database, but no success.

In this case you are using sqlite? If possible try to use a real database (mysql, postgresql), this should work in most cases but some provider use a configuration that does not work well.

Yes, I’ve tried MySQL too but I get login errors with that too. I’ve tried manually creating the DB in a number of ways, but I’m no expert on MySQL so can’t be sure that I’m doing it right.

I am currently running ownCloud on the same server and want to migrate the content to nextCloud once it all works, but looks like it’s going to be a long slow process.

My hosting service is 50Webs. They are very good on most things, so I’ll ask them, but I would expect that they’ll want to charge for support on a specific package.

The MySQL on 50Webs is managed via PHPMyAdmin. Do we have specific instructions for using that to create a DB that might help?

Hi,

I have the same problem described as installing throuhg setup-nextcloud.php with the same errors.
I do not think it is relationed with database issues because the procces fails at creating dir/files in the selected folder, both the default folder or personalized.
I have been forced to reinstall Nextcloud but a days ago I got to install it, same version, same server wich is a Debian Wheezy with Nextcloud. It was running fine but I needed to reinstall it to make the /data folder to be allocated outside the www folder to improve security.
Now I am not able to get it running again and it is so frustrating because just a few hours ago it was running so fine.

I have not much knowledge for Linux admin so I am gonna Google a bit to try to locate the problem and
I will come back if so.

Hi.

I have just make it running using improper techniques, jejeje.
I take a look at the apache error log but nothing important there. It is not a problem with the database connection because the process do not need it until reaching the next step in the installation.
I have just tried using again the proposed “nextcloud” name for the folder installation and it got running but how I do not want the “nextcloud” folder to be the definitive, I renamed the “nextcloud” installation folder during this step to my definitive name, after that I refreshed the installation page changing the renamed folder in the installation URL, and BINGO!!
In the next step I could complete the data folder location to be set (outside www folder for increased security) and the database (Mysql) connection.
The installation process made the rest of the work and now my reinstalled nextcloud is working fine again.

I think it sould be some kind of bug of the installation process.

Before you install and set up everything, make sure that you will soon get an update on that. Wheezy is really old, in theory it still has long term support until next month. It has an old php version the caching modules are not working very well, if possible use a current debian version with php 7 that you are fit for the next few version with Nextcloud (NC 14 requires at least php 7.0).