Virtual Files not working for our whole team (M1 Mac and Windows devices)

Hello everyone!
Since this is my first thread on here I am sorry if there’s been any comparable post already posted about this but my team and I are a little lost…

Some time ago we switched to Nextcloud and started off very happily. The key feature that’s most important to all of us is the virtual file sync. At first it worked on our Windows PCs but not on Mac.

I don’t know which update killed that feature for Windows but it’s a huge hassle switching to browser-only. [Current version: 3.4.4.] When I try to sync on Windows it’s showing me this error: “cannot sync due to invalid modification time”. Also tried downgrading to other versions but it always stayed the same.
Macs always got this error which goes something like “Not enough space for synchronization” … which is great because we want to save space by using virtual files but that feature simply does not work for Mac at all. (our cloud contains roughly 6TB of data as of now, rapidly growing in phases.

Now, I’m not a huge geek that can fix a lot manually and we are really getting frustrated with this missing key feature. Is there any way to fix this issue? Have you run into something similar? We are seriously thinking about switching back to another Cloud service because it’s a huge dealbreaker for us…

Kind regards,

I’m running Nextcloud Virtual Drive on Windows clients without any issue. I would put the focus on the “invalid modification time” message, this is a well-known and documented problem…