Videoplayer: Error loading filename.mp4

I had just finished setting up nextcloud, when I faced this problem. When I try to watch videos from my server on the web gui, videoplayer just displays: Error loading filename.mp4 (same error with .mov videos). Some mp4 and mov videos however play correctly. I have tried to scan all files with occ files:scan --all , but that isn’t helping. I also checked file permissions on the server and they should be right…

In the server log there are two errors like this, but I am not sure if they are related to the problem I am facing:

OCP\Files\NotFoundException: 

0. /var/www/html/nextcloud/apps/text/lib/Service/DocumentService.php - line 324:OCA\Text\Service\DocumentService->getFileById(1469, "admin")
1. /var/www/html/nextcloud/apps/text/lib/Service/ApiService.php - line 160:OCA\Text\Service\DocumentService->getFileForSession(OCA\Text\Db\Session { id: 86}, null)
2. /var/www/html/nextcloud/apps/text/lib/Controller/SessionController.php - line 81:OCA\Text\Service\ApiService->sync(1469, 86, "7/jWyfovaJ0 ... j", 0, "", false, true)
3. /var/www/html/nextcloud/lib/private/AppFramework/heyHttp/Dispatcher.php - line 170:OCA\Text\Controller\SessionController->sync(1469, 86, "7/jWyfovaJ0 ... j", 0, "", false, true)
4. /var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 99:OC\AppFramework\Http\Dispatcher->executeController(OCA\Text\Con ... {}, "sync")
5. /var/www/html/nextcloud/lib/private/AppFramework/App.php - line 125:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Text\Con ... {}, "sync")
6. /var/www/html/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47:OC\AppFramework\App::main("OCA\\Text\\ ... r", "sync", OC\AppFramew ... {}, { _route: "text.Session.sync"})
7. <<closure>>OC\AppFramework\Routing\RouteActionHandler->__invoke({ _route: "text.Session.sync"})
8. /var/www/html/nextcloud/lib/private/Route/Router.php - line 299:call_user_func(OC\AppFramew ... {}, { _route: "text.Session.sync"})
9. /var/www/html/nextcloud/lib/base.php - line 1008:OC\Route\Router->match("/apps/text/session/sync")
10. /var/www/html/nextcloud/index.php - line 38:OC::handleRequest()

How could I fix this problem?

I have enabled:
APCu for local caching,
Redis for filelocking and distributed caching,
and OPCache.

Nextcloud: 18
Apache: 2.4
PHP: 7.3
Database: MariaDB
Ubuntu 19.10.2
Server: Raspberry Pi 4

Solved!

Videoplayer cannot play videos if there are some special characters in the path. (ä, å, é, #…)

I wouldn’t say this is solved… can we get this rather fixed in the video-player plugin itself? Unfortunately I cannot modify some file names :confused:

Thx, Michal

For me it is working as a good workaround as I manage paths and filenames.
Thanks to everyone.

Hello guys.

Is there a specific solution for this issue?

I have the same problem and I also changed the special characters of the video title.

RasPi 4
NC: 21
MariaDB:10.5
Swag:1.14

Used docker to download these apps/containers. All from the Linux server.

I’m very new to this and thanks in advance.