Verzeichniss ocm-provider ist nicht mehr im Nextcloudhauptverzeichniss vorhanden

Auch von mir vielen Dank, das hat den Fehler bei mir auch behoben!

@Katzenklo Danke dir natürlich auch vielmals für deine Tipps, auch wenn die leider nicht zum Erfolg geführt haben…

OK nicht schlecht :+1:

Das zur “.htaccess” hinzuzufügen, hat bei mir geholfen - mit angepasster Pfadangabe, denn bei mir heißt der Ordner “nextcloud” anders.

Also alles super!

Danke

Danke.
Das war’s! :+1:

funktioniert bei mir leider auch nicht unter NC 27.1.3 with php 8.2 & nginx

so ein extrem nerviger Bug - der selbe Müll wie webfinger & nodeinfo, was sich nicht entfernen lässt … nur die 2 sind wenigstens nicht eine große orange Fehlermeldung

Ich konnte den Fehler in meiner nginx-Konfiguration durch hinzufügen folgender Zeilen beheben:

location = /oc[ms]-provider/ {
return 301 /index.php/oc[ms]-provider;
}

Danke für deine Idee dazu - mag mein Server nicht, bekomme ich nen nginx Config restart Error davon

Welchen Fehler gibt der nginx aus?

Ich hab meine Zeilen nach den „well-known“ locations ergänzt


location /.well-known/acme-challenge { try_files $uri $uri/ =404; }
location /.well-known/pki-validation { try_files $uri $uri/ =404; }
return 301 /index.php$request_uri;

try_files $uri $uri/ =404;
}
location = /oc[ms]-provider/ {
return 301 /index.php/oc[ms]-provider;
}

1 Like

Der fehlende Pfad Teil /nextcloud/ war auch hier das Problem in .htaccess - vielen Dank.

Das Problem trat hier nach Update von 25.0.13 auf 26.0.8 auf und nach Korrektur der .htaccess dann erneut nach dem Update auf 27.1.3.

Das war hier nicht die Lösung.

der Nginx Fehler ist “location” ist hier nicht erlaubt … :thinking:

gestern alle Fehler weg nach einer komplett neuen Nginx Config, jedoch zu früh gefreut - heute Morgen ist der Fehler zurück … so ein nerviger Müll … “/ocm-provider/” & “/ocs-provider/” … gestern alle Tests bestanden, dubioser Mist

Somit ist die aktuelle Admin Dokumentation https://docs.nextcloud.com/server/latest/admin_manual/installation/nginx.html weiterhin fehlerhaft/nicht vollständig

ENDLICH … mal gucken ob die liebe NC die Nacht dieses Mal übersteht - aber aktuell hat nginx Direktiven komplett löschen, dann ganz neu laut letztem Manual aufgesetzt & angepasst an den eigenen Server, sowie den Code Schnipsel von @Schrott-Wichtel geholfen und der Fehler wäre aktuell weg - danke nochmal für den Tip @Schrott-Wichtel :ok_hand:

Ich habe habe die letzten paar Tage geflucht und alles möglich ausprobiert. Nichts hat funktioniert. Der Code Schnipsel von @Schrott-Wichtel hat bei mir nicht funktioniert. Was hat funktioniert?

return 301 /index.php/ocm-provider;

Also nur M!! Kein S!. Warum auch immer…

Trotzdem danke für den Thread hier! Die Lösung war nur ein paar Buchstaben entfernt…

Ich weiß leider nichts damit anzufangen :upside_down_face:
Muss das wo eingetragen werden?

Hallo Zusammen,

ich habe es wie folgt gelöst:
Bei mir war in der nginx nextcloud.conf der Eintrag hier:

location ~ ^\/(?:updater|oc[ms]-provider)(?:$|\/) {
 try_files $uri/ =404;
 index index.php;
}

Der Eintrag muss auf die folgenden zwei location Einträge geändert werden:

location ~ ^\/(?:updater|ocs-provider)(?:$|\/) {
try_files $uri/ =404;
index index.php;
}
location ~ ^\/(?:updater|ocm-provider)(?:$|\/) {
return 301 /index.php/ocm-provider;
}

Hoffe es hilft jemandem.

Grüße

Chris

1 Like

Ja Danke
Und bei Apache ?

Hab wenig Ahnung von Apache.
Hast du den folgenden Lösungsansatz mal ausprobiert?

Grüße

Hat bei mir geholfen mit Plesk und Nginx

1 Like

Vielen Dank!

Hat bei mir geklappt!

1 Like