Very slow login after updating to 21.0.3

Sure, you were very clear! :smiley:
Thank you again and I too wish you a good weekend! :muscle: :sunglasses:

1 Like

All the best mate, take care.

Feel free to open any other issues that you may have.



1 Like

Hey mate did you checked this out?

Maybe that helps :smiley:


Yes, thank you, but … uh, I didn’t understand much …
I hope the author has the great patience to answer me a little more simply, for ignorant people like me! :blush:


That’s a very good contribution. Thanks Beltran1337 :slightly_smiling_face:
I did also the Upgrade from 20.0.6 to 21.0.1 … and i see too, that the login process is slow … but, it was some kind of slow before, too :sleeping:

One reason for the slow login in the past was the Dashboard app …so i had some users, that needed about 1 minute to login, others (like me), not.
What i did as workaround … i created a Dashboard group for such users, who are not affected by the Dashboard slow login and assigned them to this group and other, who are affected, i do use another group.

Thanks all for your great hints about.

1 Like

Hey there, hope your doing well and safe.

I realized that on my production too, what you did was a great call. Thank you for sharing.

Have a nice weekend mate, good luck with your NC.

All the best!!


Happy Sunday everyone,
desperate, I gave up and reinstalled everything from 0: now it works like a wonder! :+1:


Good morning mate, hope you are doing well.

That’s nice to hear, sometimes all we need is a fresh start.

Good job! :smiley:

1 Like

Hello my dear!
Thank you very much!
Good week and good job to you too! :smiley:

1 Like

Good evening everyone,
sorry if I re-open this thread, but I still have the same problem: i have a small server with Apache2, mariadb, php7.4 Ubuntu 20.4.2 server and I just updated, via the stable channel, from 20.0.11 to 21.0.3, but it became very slow when I log in from browser and when I use Android apps , also from my pc with Ubuntu, I can’t access the folder, a window appears that says that the time out has been reached.
On settings, Nextcloud warns me about this:
A background process is pending that checks the SSL certificates imported by the user. Check back later.
but I have no idea what that means.
Can anyone help me please?
Thanks so much!!!

@mercurio do you use collabora server app ?

and thank you for your attention!
No I don’t have it, as apps I only have: dashboard, files, photos, tasks, contacts, calendar and notes.
I have never installed memcache, because it never succeeded, but it never gave me problems in previous versions.

@mercurio have you enable opcache and php-fpm ?

those methods allows to cache php but it use more RAM ( not a lot)

Mhmm opcache yes, I’ve always configured it according to the documentation, but php-fpm I don’t know what it is … doce check? In the php config file?

Forgive me for the ignorance: if this were the problem, why with the previous versions of NC I never had difficulties?

@mercurio php-fpm is a module of PHP which allows more performance for PHP.

I don’t think this is the real problem but it can reduce the load of your pages.
Your CPU is overloaded or not? if not no need to install it.

maybe more info about your nextcloud server can help us. ( ram allocated for PHP, your CPU load, … maybe some logs about this but not sure if there are any.

Hi @Mageunic
and I’m sorry if I only answer you now!
So I managed to modify the php-fpm parameters, and now I put these:
pm = dynamic
pm.max_children = 120
pm.start_servers = 12
pm.min_spare_servers = 6
pm.max_spare_servers = 18
unfortunately it always remains slow …
For the other information you asked me, I can tell you this:

  • my cpu is AMD Athlon ™ II X2 260 Processor (2 cores) and it doesn’t seem overloaded;

  • PHP
    Version: 7.4.21
    Memory limit: 4 GB
    Maximum execution time: 3600
    Maximum upload size: 1.9 TB

  • Database
    Type: mysql
    Version: 10.3.29
    Size: 77.2 MB

Is this useful information?

Nobody can help me, please? :sob:
I know I’m not an expert, sorry and thanks for your patience!!! :bowing_man: :bowing_man: :bowing_man:
I managed to configure Redis, I configured php-fpm, I configured cron instead of ajax, in “settings” it tells me that all the checks are passed, the Nextcloud security scan gives me the result A, the ssllabs check. com gives me the result A +, so why is it slow?

HI @mercurio, sorry I can’t help you … check if someone else has already solved the issue on other topics.

It was happening to me after adding my SSL certificate.
The steps under “Allow access from nextcloud sync apps” fixed it for me:

1 Like

Hi @Mageunic ,
do not worry! Indeed, I thank you very much for the attention and help you have given me, really! :bowing_man: :blush: :beers:
I will try to do further research, also hoping for a resolution with the new updates.