Using spreed-webrtc on Raspbian (Raspberry 3)

Hi,
I’m trying to install the spreed-webrtc plugin on Raspbian but I can only find the Ubuntu package. Is there any easy way to install spreed-webrtc on Raspbian or maybe detailed install/build How-Tos which can help me to set up spreed-webrtc properly? I managed to build the spreed-webrtc Server but now I don’t know how to set up the nginx Server, how to autostart the spreed-webrtc and how to set up a letsencrypt certificate with renewal cron job. I’d really appreciate if someone could write a tutorial or create a package.

Thanks!

Hi,

we have a ppa for Ubuntu at https://launchpad.net/~strukturag/+archive/ubuntu/spreed-webrtc but as of now it does not contain armhf or arm64 packages. You could rebuild that package for armhf by following instructions like here. I will check what needs to be done to get armhf and arm64 packages on Launchpad.

Cheers

Regarding the configuration for Nginx we have an example Nginx configuration in the repository.

And last the letsencrypt is more or less unrelated to Spreed WebRTC or Nextcloud but i suggest you look into https://github.com/lukas2511/letsencrypt.sh which has all you need. There are some PPAs for this tool out there as well.

Cheers

Hi,
Thank you for the quick reply. I’d really appreciate a Raspberry ppa because at the moment the build and setup process is not easy and probably stops many nextcloud users from installing spreed-webrtc on Raspberry Pis or other arm devices…

1 Like

I’d like to see a armh build too; for odroid xu4

The development PPA for Spreed Webrtc at https://launchpad.net/~strukturag/+archive/ubuntu/spreed-webrtc-unstable now has armhf packages for Ubuntu 14.04 and 16.04.

sudo apt-add-repository ppa:strukturag/spreed-webrtc-unstable
sudo apt-get update && sudo apt-get install spreed-webrtc

Please let me know how it goes.

1 Like

Thank you! Will try it and report here. :slight_smile:

Unfortunately I didn’t manage to install it on Raspbian (error: could not find a distribution template for Raspbian/Jessie). Maybe you can add it to the supported distros?

I also tried to download the debs directly and to install them with the package manager without success.

Thank you!

Installation under Ubuntu 14.04 LTS on odroid xu4 works…
The server is up, but if I call it through nextcloud or throu /webrtc/ it first shows the spreed logo and than “Failed to load app!”

I’ll have a look on it later on or at the weekend…

From the log:
server 2016/07/28 07:44:24 Got signal 15, stopping all services
server 2016/07/28 07:44:24 Stopped HTTP server on 192.168.1.234:8688
server 2016/07/28 07:44:24.174417 Warning: sessionSecret value is not a hex encoded encoding/hex: odd length hex string
server 2016/07/28 07:44:24.174650 Warning: encryptionSecret value is not a hex encoded encoding/hex: invalid byte: U+0074 't’
server 2016/07/28 07:44:24 Using ‘/webrtc/’ base base path.
server 2016/07/28 07:44:24.174872 Enabled modules: [youtube presentation contacts screensharing]
server 2016/07/28 07:44:24.184143 Loaded extra templates from: /var/www/owncloud/apps/spreedme/extra
server 2016/07/28 07:44:24.184259 Using the number of CPU’s (8) as GOMAXPROCS
server 2016/07/28 07:44:24.184293 Max open files are 1024
server 2016/07/28 07:44:24.188777 Enabled users handler 'sharedsecret’
server 2016/07/28 07:44:24.189264 Added URL handler /extra/static/… for static files in /var/www/owncloud/apps/spreedme/extra/static/…
server 2016/07/28 07:44:24 Starting HTTP server on 192.168.1.234:8688

Found the error:

:/var/www/owncloud/apps/spreedme/extra/static/owncloud.js

has to be renamed to

:/var/www/owncloud/apps/spreedme/extra/static/nextcloud.js

Now it works! :slight_smile:

Well, launchpad is an Ubuntu tool and thus does not make it possible to provide repositories for other distributions than Ubuntu. But it should work when you download the package directly assuming your Raspbian is mostly compatible with Ubuntu 14.04. Could you post the full output so we can see what happens when you dpkg -i the package on Raspbian.

Yes, thanks for confirming :thumbsup:

I installed golang-spreed-webrtc-dev_0.27.1-1~trusty2_all.deb first (sudo dpkg -i and then sudo apt-get -f install for dependencies). Then I installed spreed-webrtc-assets_0.27.1-1~trusty2_all.deb and spreed-webrtc-bin_0.27.1-1~trusty2_armhf.deb without any errors (both with sudo dpkg -i). At least I tried to install spreed-webrtc_0.27.1-1~trusty2_all.deb (sudo dpkg -i) and got this error:

spreed-webrtc-bin (0.27.1-l~trusty2) wird eingerichtet ... pi@raspberrypi: /spreed-webrtc $ sudo dpkg -i /home/pi/Downloads/spreed-webrtc_0 .27.1-l~trusty2_all.deb (Lese Datenbank ... 101068 Dateien und Verzeichnisse sind derzeit installiert.) Vorbereitung zum Entpacken von .../spreed-webrtc_0.27.1-l~trusty2_all.deb ... Entpacken von spreed-webrtc (0.27.1-l~trusty2) über (0.27.1-l~trusty2) ... spreed-webrtc (0.27.1-l~trusty2) wird eingerichtet ... dpkg: Fehler beim Bearbeite^ des Paketes spreed-webrtc (--install): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 102 zurü ck Fehler traten auf beim Bearbeiten von: spreed-webrtc pi@raspberrypi: /spreed-webrtc $ sudo apt-get -f install Paketlisten werden gelesen... Fertig Abhängigkeitsbaum wird aufgebaut. Statusinformationen werden eingelesen.... Fertig Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benöti gt: golang-context-dev golang-mux-dev golang-uuid-dev golang-websocket-dev Verwenden Sie »apt-get autoremove«, um sie zu entfernen. 0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert. 1 nicht vollständig installiert oder entfernt. Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt, spreed-webrtc (0.27.1-l~trusty2) wird eingerichtet ... dpkg: Fehler beim Bearbeiten des Paketes spreed-webrtc (--configure): Unterprozess installiertes post-installation-Skript gab den Fehlerwert 102 zurück Fehler traten auf beim Bearbeiten von: spreed-webrtc E: Sub-process /usr/bin/dpkg returned an error code (l)

Mhm that looks strange. From looking at the postinst script i fail to see how this could exit with 102. Could you please try to run the postinst script manually and post the output please.

sudo /var/lib/dpkg/info/spreed-webrtc.postinst configure

Thanks for your help!

To whom it my interest…
…update to 0.27.1-2 on ordoid xu4 from the repository ppa:strukturag/spreed-webrtc-unstable worked without problems…

Get:1 http://ppa.launchpad.net/strukturag/spreed-webrtc-unstable/ubuntu/ trusty/main spreed-webrtc-bin armhf 0.27.1-2~trusty1 [1405 kB]
Get:2 http://ppa.launchpad.net/strukturag/spreed-webrtc-unstable/ubuntu/ trusty/main spreed-webrtc all 0.27.1-2~trusty1 [32.3 kB]
Get:3 http://ppa.launchpad.net/strukturag/spreed-webrtc-unstable/ubuntu/ trusty/main spreed-webrtc-assets all 0.27.1-2~trusty1 [1551 kB]

Any update on running spreed-webrtc on Raspian?