Users can't find music from shared folder

I have my music saved on the NAS server and (as admin) created a shared folder with everybody (in read-only mode). The problem is they can browse the folder and play each file individual, but when going to the audioplayer it won’t find them. Even a scan as normal user shows 0 songs.

Is this a limitation of the AudioPlayer that it can only play users own files?


While another user shared a music folder with me and I am able to play all the files in the audio player, I can tell that audio player is supporting that. No limitation there.
Did you check that there is no hidden file (I think it should be named .nomedia or .noaudio or something like that), that tells the audio player to not search in that folder for music files?

Thanks for your response.

I did a full folder scan searching for any files starting with “.no” but couldn’t find any. So that doesn’t seem to be the reason.

As admin I can do a folder scan and it finds all the music. As normal user it doesn’t show it and if I do a folder scan (using the occ command) it doesn’t find any files.

My music folder is created as an external SMB share (from my NAS) which is then shared with normal users (including myself). Not sure if that makes a difference

Okay, I see.
Just to have it here documented correctly: audio player ignores folders that contain the file

I just checked again.
While this isn’t the problem for you, is there something in the logs?

When you go into the audio player and you make a selection for “folder” (instead of “playlists” or anything else), the folder you’re looking for is not displayed, right?

Well I fear the SMB share is really making the difference here. With a normal share it is working fine on my server. But let’s see if the logs help. Or someone else has more expertise with SMB shares in Nextcloud.

Audio Player generally plays shared audio files – as Local Shares as well as Remote Shares.

@StephanW Please open a new issue on GitHub with detailed info using our template so we can track the problem.

Right, that is documented here:

Shares, the share folder, and the media folder are not so simple on External Storage.

I am using the same - in fact this was the case for myself which brought me to bring the Audio Player to life.

when you do an occ scan with the --debug mode, what is written there?
Please us a GIT Issue to report the details. it will give us all the background we need to know here

I think I have the same problem.

When I share an externe music folder directly with the plug-in “External Storage Support” to the user : I am able to scan the musics from that folder.

But when I only allow the “admin” account to see the music folder, in “External Storage Support” admin options, and I share this folder, from this “admin” account, to a user with the share option of the music folder : the scan finished as well but without finding any music files.


(For information : I use the share option of the folder instead of sharing with external storage because I want to share it in readonly mode. By the way, I tried to share this way (i.e. directly from the folder) with the permission to modify : I had the same issue.)

Thanks for your help.

PS : I also tried with all share options enabled (in the admin panel) and with chmod 777 on the folder : I had the same issue

I experience the same problem. If I share a folder the other users can see and play the files individually but scanning of the share does not work. Files are found but none included .
If I make the share writable it works fine.

does this problem really still exist? (NC 20)
users can play individual files from shared folders.
But they cannot just play a whole directory.
Clicking the “three buttons” next to the directory they cannot choose to “play” (just Download i.e)

I just ran into this problem too, but with some details:

Folders on a file share that I, as a user, never opened yet, do not get imported in the audio player. After opening the artist folder in the file manager (my folder structure is music/[artist]/[album]/[song].mp3), it will get imported.

this is ok, because its the way NC works.

Audio Player (and any other app) can only see the files that were added to the _filecache table in the backend. this is like the inventory of all files.
Files are added there when they are first “seen” by NC.

does this help?

In your case, someone shared a folder but only his user-id has the entries in the filecache.
As as soon as you enter the folder, NC will index the folder and then add the entries to the filecache.
the only way to get around this in an automated way is to use the

occ files:scan

command. This might be a way for many users. I had the same with the shared libraries for my kids. had to enter the ones.

Since Nextcloud 21 you do not need an Audio Player.
Nextcloud can play in web (user GUI and shares) MP3 in HTML5.

You can test it at (actually Nextcloud
Create an 60 minutes account and upload a mp3-file.

Then you can surf through the directorys (i think including e.g. “local”) and play the music without rescan all files.

yes, thats correct. shared player was removed from AP since I think NC18 or so, because its out of the box. files, I did not recognize.

for playing single files, you don´t need Audio Player nor Music app.
Its just as soon as you want to index them and work with big libraries and their meta tags

Thanks for your answer.

But i think in Nextcloud 20 it does not work out of the box.
Here an example at .

yes - i can also explain that :slight_smile:

you shared a folder. this uses the “files app” to display the files. and this is the html5 stuff that was only added recently.
if you would share the file itself, it should work out of the box

Thanks. Yes it works on direct link:

But with Nextcloud 21 it also works in directory.

correct. this is still the “old” way where the audio player plugin is loaded.
the alignment seems to be a little off :relaxed:

And this is the version Nextcloud 22 link on bbb.mp3 in public shared directory.

jep. correct. with the next AP update I will also remove my old stuff in favor for NC standards